0

After doing a restore from an old iPad to a new iPad, and syncing up iCloud, contacts stored without a country code are displayed incorrectly.

In Australia, the mobile number format is 04xx xxx xxx, or +61 4xx xxx xxx (with country code).

The result of this is that text messages (or iMessages) received are not matched up to a contact. Additionally, the phone numbers appear in the incorrect format in the Contacts app (04x xxxx xxx), suggesting it is maybe assuming an American country code or something.

The iPad does not have a SIM card in it. I tried putting a working Australian SIM card in it, and it immediately fixed the problem... until I removed it and everything went back to how it was.

Does anyone know how to change this default without having a SIM card permanently installed? Seems like there should be a setting for this somewhere, but I cannot find anything. I've googled and the closest I can find is a setting called "Internationale dial assist" inside Settings > Phone but this area doesn't exist on an iPad and I cannot find anything similarly named. Any help would be very much appreciated!

1

Please check the settings under

Settings > General > Language & Region:

  • iPhone Language: English (Australia)
  • Region (Australia)

Ideally your iPad should detect your contacts' numbers correctly now, but it doesn't hurt to restart your device.

Also, after setting the settings above you may need to sign out of iMessage and log in again.

  • Thanks for the response. Unfortunately this was the first thing I checked, everything was set correctly. Remember that putting in a SIM card immediately fixed he issue, and remov Ng it immediately reversed it. – JoGoFo Oct 11 '16 at 21:42
  • Have you disabled Dial Assist? – oa- Oct 11 '16 at 21:44
  • The setting for Dial Assist is in "Phone" which doesn't exist on an iPad :( and I couldn't find it anywhere else – JoGoFo Oct 12 '16 at 10:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .