0

New to using mac os. I was attempting in installing Mac OS X 'Yosemite' on a mid 2010 macbook pro.

[Earlier before I started the whole process, I accidentally deleted everything (main harddrive) from disk utility including the bootcamp.]

I created a bootable USB with Yosemite on it, during the process, at the part where I am suppose to erase the main harddrive, I ran into "erase process has failed." = unable to erase the harddrive.

I've tried first aid, erasing and etc = "erase process has failed"

[After watching this video; youtube.com/watch?v=o6s4GZWG7M0 I noticed that I am missing "Bootcamp"]

1) How do I erase my hard drive if I keep getting "erase process has failed" when I attempt to?

2) Does not having a bootcamp underneath my hard drive disallow me from erasing my main hard drive?

[EDIT]

Adding photos as requested by Monomeeth in comments:

Additional images; I'm able to successfully erase the "2nd" HD but when I attempt to erase my main HD it fails.

ran command: diskutil partitionDisk disk0 1 GPT HFS+ Mac_HD 100%

ran command: diskutil list

ran command: diskutil unmountDisk force diskX

/

ran command: sudo diskutil unmountDisk force disk0

Attempted to recreate a bootable USB with Yosemite on it, which was successful But

Still wasn't able to format internal HD.

Skipped to step 6

1

Answer to question 2

No, not having Bootcamp does not prevent you from formatting the Mac's internal drive. In fact, the great majority of Mac owners do not have Bootcamp installed. Bootcamp is simply a tool released by Apple that allows Mac owners to install and boot their Macs natively into a Microsoft Windows installation. This happens alongside an existing macOS installation, but does not allow you to run Windows and macOS concurrently. It is a good option if you need to run Windows programs that are CPU-intensive in nature and don't lend themselves to working well in a virtual machine (such as ones set up with Parallels or VMWare Fusion).

Answer to question 1

I've looked at the photos I asked you to post and the second option after booting up from the USB should be Install OS X, not Reinstall OS X. This implies to me that you're USB is not in fact bootable because the 'Reinstall' option would normally appear when booting from the Recovery partition.

Can you try choosing the Reinstall OS X option instead to see whether you're able to successfully install a version of OS X. Let us know how you go.

Also, the photo of the error you get provides a lot more information. Basically the reason you can't erase the drive is because it can't be unmounted. This tells us a lot more about what may be going on, so if choosing the Reinstall OS X option gives you no joy then we've got more info to work with.

[EDIT]

Since you're unable to unmount the internal drive, and since the various terminal commands haven't worked, I strongly suspect that my earlier suspicion is correct - that your 'bootable' USB is in fact not bootable. Your question doesn't detail how you created the bootable USB, so let's start again using these steps:

  1. Recreate your bootable USB. Since you're limited to doing this on Windows, follow the steps in this article.
  2. Plug the USB into your Mac.
  3. Switch the Mac on and immediately press the Option key.
  4. When you see the choice of drives, select the USB.
  5. Once the OS X Utilities window appears, select Disk Utility.
  6. Try to erase your internal drive and see if you're now able to erase the disk. If unsuccessful take note of the error message etc. Regardless, go to the next step.
  7. Exit Disk Utilities and select Install OS X.
  8. Follow the steps to install OS X.

If you fail at either (or both) steps 6 and/or 8, please report back with what happens.

  • Oh okay, that would make sense. But how come I am unable to erase my hard drive? – Johnny Oct 11 '16 at 13:10
  • That's exactly what we need to determine. When you get a chance, can you please take a photo of the following and add them to your question: (1) the MBP screen after it's finished booting from your USB but before you do anything; (2) the MBP screen just before you click on Erase; and, (3) the MBP screen showing the error after failing to erase the HD. – Monomeeth Oct 11 '16 at 13:57
  • Added to comments underneath my post. – Johnny Oct 11 '16 at 17:43
  • Can you confirm that when you are presented with the Booting option that you are actually selecting the USB disk (i.e. you are not selecting the Recovery option)? If you've been selecting the Recovery disk, try selecting the USB disk and let us know how you go. – Monomeeth Oct 11 '16 at 20:25
  • I can confirm that i've been selecting the USB disk. – Johnny Oct 11 '16 at 20:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .