1

I got an iPhone 7 that has a freezing issue with the Phone app. I purchased it directly from Apple and use it on Verizon's network. During the purchase, Apple.com asked about transferring an existing phone number, which I did. When the phone arrived, I didn't do any special setup; just used the sim card already installed in the phone and followed the on-screen setup steps. I set up the phone without doing any restore from a different phone (thus a clean setup). (This was shipped on the first day of iphone 7 shipments in the US, if that matters.)

Pretty much immediately I noticed that the Phone app would freeze occasionally and remain frozen. This seems to happen after not using the Phone app for a while. I'll open the app, and none of the tabs or buttons work. The only thing I can do is press the home button and I immediately get returned to the home screen.

When I try opening the Phone app again, it will remain unresponsive. After several opens and closes (again, via Home button, so not an official shutdown of the app), it will eventually start working, or will restart on its own (meaning, the app will just close on its own instead of me clicking Home). Once it officially closes, it'll work fine when I reopen it. I haven't ti

I'm also wondering if this is somehow related to an odd outstanding issue I have with Google Maps (where its turn-by-turn directions don't play when the screen is off or the Google Maps app is not focused). The two being related seems unlikely, but both bugs seem like atypical behavior, so who knows.

I've confirmed this issue has continued after a restart of the phone. I have not tried a full restore of the phone (would prefer to avoid that if I can). Aside from this, any other suggestions on my Phone app problem? Or suggestions on what I can do to debug it further when it happens again?

Update (Oct 18, 2016): I tried a hard reset (holding Power + Volume down for several seconds until some msg/logo appeared on screen), but the problem continued this morning. This time, I was on a call and we ended call. I went into Phone app to make a new call, it was unresponsive and there was a mild constant tone playing in speaker; hitting Home didn't fix; and eventually Phone app restarted itself.

Update (Oct 30, 2016): I spoke with AppleCare a few weeks ago, and they had me reset the Network Settings. After doing this, the issue disappeared for 4-5 days, but then started again. Now the phone app freezes 1-2 times a day, so still an issue.

Update (Dec 7, 2016): Still an issue with phone freezing everyday; now there's other apps freezing (calendar, email, etc). I'm at least seeing many others on the Apple forums are having this issue, along with a note on PhoneArena.com -- even after doing a full reinstall of the phone. Hopefully a new software version fixes this -- very frustrating.

  • 1
    Have you done a hard reset? (Hold down power button and home button simultaneously.) A full restore, while taking some time, is always a good step to tackle intractable problems. – IconDaemon Oct 10 '16 at 23:30
  • I'll try the hard reset and report back. (And then try the full restore if hard reset doesn't work.) Thanks! – Dolan Antenucci Oct 10 '16 at 23:34
  • 1
    @IconDaemon on iPhone 7 you need to use the Power and Volume down buttons, as the home button isn't really a button. – At0mic Oct 10 '16 at 23:41
  • 1
    Just got my iPhone 7 today. IronCraftMan is correct. – IconDaemon Oct 11 '16 at 23:33
  • 1
    I have been having the same problem with my iphone 7, phone unresponsive after some time of no use. I did a soft reset, a network setting reset, turn airplane on and back off, a hard reset, took the sim card off and put back on, set it up as new from scratch (no backup), took it to the genius bar, device was replaced for a new one but I still have the problem. I am still scratching my head researching for a solution. I think that this may be a software problem as I have had the same problem in two different devices. I'm on the Verizon network also which may lead to think on a network issue. – Lopez Taracena Oct 13 '16 at 16:36

You must log in to answer this question.

protected by Community Oct 13 '16 at 20:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged .