4

I recently got El Capitan 10.11.6 installed on my MacBook. Now whenever I try to install ANY 3rd party font, they fail font validation in the Font Book app.

The error is always:

1 serious error was found. Do not use this font.

This occurs for ALL 3rd party fonts. Fonts I download from Adobe Typekit. Fonts I download from Google Fonts, etc. Every single one.

Some websites suggest that I go ahead and install the font anyways. I tried this and certain programs become unresponsive. For example Illutrator CC 2015.3 will not even start up (gets stuck at Initializing) but then once I remove the "bad" font, Illustrator works fine again.

What am I missing here? How do I fix this problem?

UPDATE

As requested here is the Validation Error report from installing a font. The only thing I changed is the network path name for the font location (it was on a network drive).

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<array>
    <dict>
        <key>file</key>
        <string>Nudista Medium.otf</string>
        <key>path</key>
        <string>/network/path/nudista/Nudista Medium.otf</string>
        <key>report</key>
        <array>
            <dict>
                <key>fail</key>
                <integer>1</integer>
                <key>fontname</key>
                <string>Nudista Medium.otf</string>
                <key>pass</key>
                <integer>0</integer>
                <key>ruleslist</key>
                <array>
                    <dict>
                        <key>author</key>
                        <string>com.apple.ATS</string>
                        <key>kATSFontTestDescriptionKey</key>
                        <string>This font has failed one or more of a series of tests of the font interacting with OS X. If you use this font, you may experience text problems or application crashes. Please contact your font vendor for a repaired version of this font.</string>
                        <key>kATSFontTestNameKey</key>
                        <string>System Validation</string>
                        <key>result</key>
                        <false/>
                        <key>severity</key>
                        <string>ERROR</string>
                        <key>version</key>
                        <integer>65536</integer>
                    </dict>
                </array>
                <key>run</key>
                <integer>1</integer>
                <key>warn</key>
                <integer>0</integer>
            </dict>
        </array>
    </dict>
</array>
</plist>
  • Maybe change your GateKeeper settings to allow all... then see. Not sure what else could be the issue. – bret7600 Oct 10 '16 at 23:39
  • This just started happening to me too. There are at least 10 threads over the last 5+ years on discussions.apple.com discussing this problem, with no solutions. – dfan Jan 31 '17 at 16:00
  • Could you try to do the following: - Open the font - Install it - Wait for the validation error message - Menu: "File" > "Save Report..." - Upload the report here, I'll check it for you ;) The report is in fact a simple ".plist" that can be opened in text mode or with Xcode. I just discovered this option not too long ago! ![FontBook hidden "Save Report" menu](i.stack.imgur.com/6Q6Lr.png) – Joël May 9 '17 at 9:12
  • I had this problem, but was able to install the fonts if they were in the Desktop folder. – SArcher Oct 2 '17 at 19:30
6

I've been having the same problem. What has worked for me has been to install an app called Typelight. I go into Typelight, open the font that I downloaded to my computer but didn't install yet, and then save the font to my DESKTOP. It doesn't work if I save it anywhere else, don't ask me why. After that, I open the font by clicking on it on my desktop, then I click "install", and it works with no error messages. More of a hassle, yes, but at least it's a way around the problem.

  • 4
    I had the same issue as the original poster. For me, installing fonts from ~/Desktop (or a subdirectory thereof) was sufficient to get rid of the "serious error" warning. I also have no idea why the files need to reside inside ~/Desktop. I didn't need to use Typelight. – dfan Jan 31 '17 at 19:13
  • Same problem. macOS 10.12.6. Seems to be related to the permission of the directory where the font is. Copying the font to any directory with sufficient permission can solve the problem, such as ~/Downloads, ~/Desktop. Seems like a bug with Font Book. – PickBoy Feb 13 '18 at 8:38
2

Not actually ever heard of this, but you can apply some basic troubleshooting assuming that the downloaded fonts are not damaged by the process or when they are written to your HD.

  1. Boot into Recovery mode (hold Command R at boot) and run Disk Utility and repair the disk. If you get persistent errors let us know what they are and/or try another disk repair utility (Diskwarrior, etc.)
  2. Run a cleaning utility, like Onyx and let it clean everything on the computer (Automation tab) and reboot. This may clean up damaged caches.
  3. Download the El Capitan Combo Updater Quit out of all Apps and run it. This may fix damaged parts of the OS.

It IS unlikely that all fonts you download are damaged, those three steps should help eliminate some of the more obvious possibilities.

You must log in to answer this question.

protected by Community Oct 3 '17 at 6:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .