0

Anybody knows how to fix Adobe Illustrator CC 2014 on Sierra? The app just dont open anymore. I was using it on a clean install of El Capitan, but after Sierra, the app crash right after toolbars appear.

Things that I tried:

  • Set 755 (read/write permissions) on /Library/Application Support/Adobe, ~/Library/Application Support/Adobe.

Result: App crash.

Path:                  /Applications/Adobe Illustrator CC 2014/Adobe Illustrator.app/Contents/MacOS/Adobe Illustrator
Identifier:            com.adobe.illustrator
Version:               18.0.0 (18.0.0)
Code Type:             X86-64 (Native)
...
Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000068
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

VM Regions Near 0x68:
--> 
    __TEXT                 0000000100000000-00000001014ca000 [ 20.8M] r-x/rwx SM=COW  /Applications/Adobe Illustrator CC 2014/Adobe Illustrator.app/Contents/MacOS/Adobe Illustrator

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_c.dylib               0x00007fffb20ad6c0 flockfile + 4
1   libsystem_c.dylib               0x00007fffb20af38f fread + 31
2   com.adobe.amtlib                0x0000000107ecd4d9 0x107ea0000 + 185561
3   com.adobe.amtlib                0x0000000107ec210b 0x107ea0000 + 139531
4   com.adobe.amtlib                0x0000000107ea2bf7 AMTPlugPlugRequest + 81
5   com.adobe.PlugPlugOwl           0x000000011da9e2ef int boost::_bi::bind_t<int, int (*)(char*, int), boost::_bi::list2<boost::arg<1>, boost::arg<2> > >::operator()<char*, int>(char*&, int&) + 49
6   com.adobe.PlugPlugOwl           0x000000011da9cf01 boost::detail::function::function_obj_invoker2<boost::_bi::bind_t<int, int (*)(char*, int), boost::_bi::list2<boost::arg<1>, boost::arg<2> > >, int, char*, int>::invoke(boost::detail::function::function_buffer&, char*, int) + 28
  • Start application with sudo.

Result: App wont open.
Log in Terminal The application with bundle ID com.adobe.illustrator is running setugid().

  • Reinstall software (Install only run with sudo).

Result: After install, first run with sudo, and App not even open after accepting the license. No logs, no crash.

  • Create another user (Edit 1).

Result: The app not even bounce on Dock,

  • Illustrator CC 2015 Trial, Installer only with sudo. First run with sudo, then crash. Updated to 2015.2.1 again only with sudo. Now there two results (Edit 2).

Result 1: With sudo, The application with bundle ID com.adobe.illustrator is running setugid(), which is not allowed.

Result 2: Without sudo, maybe this is a big clue:

/Applications/Adobe\ Illustrator\ CC\ 2015/Adobe\ Illustrator.app/Contents/MacOS/Adobe\ Illustrator ; exit;
2016-10-10 12:37:18.454 Adobe Illustrator[2481:60401] AdobeCrashReporterInitialize: executionTime = 0.003444 seconds
2016-10-10 12:37:25.209 AdobeIPCBroker[2490:60500] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0x1703, name = 'com.adobe.AdobeIPCBroker'
See /usr/include/servers/bootstrap_defs.h for the error codes.
Segmentation fault: 11
logout
  • Lastest version of Illustrator on CC, install only work with sudo, download ok.

Result: The app not even bounce on Dock.

Maybe it is a lost cause... for now moving to another app.

  • 2
    I read that earlier versions of the Adobe suite do not work well (or at all) with Sierra. Check out this link and see if your version is listed as having compatibility issues. – TMHahn Oct 9 '16 at 23:53
  • @Frysk thanks for the link. Issues on Sierra for now only Lightroom and Photoshop, according with this link. I'm keeping looking for a clue in adobe support forum. – Vagner Oct 10 '16 at 0:03
  • Using sudo is messed up. These apps don’t need that at all. You’ll also want to get the latest update. Don’t run 18.0.0 but get the most recent 18 and then install. – bmike Oct 20 '17 at 22:02
1

Was this a clean install of Adobe or an "restore" from a Time Machine backup? I have personally had issues when going from one issue to the next (Mavericks to Yosemite and Yosemite to El Capitan) and migrating my software instead of clean installing it. Doing a clean install fixed my issue each time.

So, first thing to do, is uninstall and do a clean installation of Illustrator.

At the time of this writing, Adobe wasn't experiencing any issues with Illustrator. See macOS Sierra (10.12) compatibility FAQ | Creative Cloud

However, they do provide a link for people to report bugs. If doing a clean install doesn't solve the problem I would report the problem.

  • It was clean install. Steps done, remove adobe folders (~/library, /library, /applications, /applications/utilities) and cleaner tool, this was made for CC 2014 and CC 2015 trial. – Vagner Oct 10 '16 at 16:46
  • One more thing...for my install of Illustrator under El Cap, I had to download the correct version of Java. Make sure Java is updated correctly – Allan Oct 10 '16 at 16:53
  • Thanks for the tip, but I'm not using Java at all, and under El capitan everything was fine. I only saw things about install Java on installation of CS6. – Vagner Oct 10 '16 at 18:00
0

I had the same, identical error that you were receiving

Reinstall worked for me - First, I had to update to Java 8, so that I could use the updated Adobe App Manager. To find the Adobe App Manager, search Google for "other adobe downloads" then go to

other adobe downloads

From there, I selected Macintosh, once you download and install the updated Adobe App Manager, then launch and follow the steps to re-install. It seemed to disappear after confirming my Serial Number, then I re-launched the Adobe Illustrator installer, re-entered my Serial Number and it installed.

Once it finished, I launched Adobe Illustrator CS6 with no problem

  • Thanks @KRONUS, CS6 seems work with no problem, after installing the proper Java version. That's not exactly my case, I'm trying to run a CC version (any, 2014, 2015, lastest), but none of them is working, not even installing with proper 'hack'. For while moving to Affinity Designer, cheaper and care about who use their software. – Vagner Oct 20 '16 at 12:44
0

We have Illustrator CS6, 2014, 2015, 2015.3, 2017 running on clean installs of Sierra that we update to 10.12.6 and then run the Adobe installers.

You may be trying to hard with sudo and all the attempts. I would probably make a new os install (wipe the drive after you backup or install on to an external drive) then only install your Illustrator.

At that point you can decide to migrate users or data or decide to move on to a newer version. Adobe is hard and all the versions are hard. I would choose 2015 if you worry about file changes to layout - 2015 runs so much better than 2014 with no downside for file interoperability we have noticed.

-1

Try deleting the Adobe .plists in Library/Preferences

  • Welcome to Ask Different! We're trying to find the best answers and those answers will provide info as to why they're the best. Answers should be self-contained so explain why you think the answer you provided will solve the problem or is better than others out there. Providing links as supporting information can also help the OP, and others, find additional info for themselves. See How to Answer on how to provide a quality answer. - From Review – fsb Mar 21 '17 at 13:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .