0

I have a MacBook Pro late 2011 and I have installed Kali Linux in dualboot. Apparently there is nothing going wrong with my jack but I have noticed that a red light is constantly turned on in the port. How can I solve it?

  • Ok so definitely i can't do anything to fix it :( anyway... thank you all for answering !! :) :) – Andrea Zedda Oct 10 '16 at 7:55
1

This is a long standing linux driver issue. I installed linux on my first macbook back in 2008. The optical audio light was never on before and it never went off after I ran linux. Even after wipe and reload of OS on a new hard drive. You can complain to the ALSA developers but you probably won't get anywhere. I never had audio problems because of it, everything worked fine except that light was on. You easiest solution is to ignore it or put a plastic plug in it.

0

The red light coming from inside the headphone jack is an optical audio signal. This computer provides an optical audio output through the headphone port. Generally, unless an optical audio output is plugged into the port, the light is turned off by macOS (or boot camp hardware drivers on windows) However, Linux doesn't keep the light off. This is what you are seeing.

That being said, I don't know how to turn off the light in Linux.

0

You can solve by this way!

" Have you tried using alsamixer to mute some of the channels? For me, on my Macbook Pro 7-1, I muted something called spdif-1 (or something similar) and that turns off the red light, while leaving everything else unmuted."

source:https://ubuntuforums.org/showthread.php?t=2019039

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .