3

One thing I never do is to connect to foreign Wi-Fis. But my iPhone decides to automatically connect to those.

iPhone connected to foreign Wi-Fi

Translated:

Welcome to the Telekom HotSpot (german network provider). You are connected to the internet via your SIM over Wi-Fi and are using your HotSpot flatrate. There will be no additional cost.

Unfortunately I've seen the message half an hour later so I assume I already sent data via a foreign Wi-Fi in the background. How do I stop the phone from connecting to new, for me unknown wifis, without turning Wi-Fi off completly? Is this a general 'feature' or only in branded iPhones?

  • 1
    There should be a Profile in Settings > General that tells it to connect to these networks. It was most likely installed by your Cellular Provider. – At0mic Oct 9 '16 at 15:48
1

iPhone will only auto-join networks that are set to be joined automatically — it won't connect to any random network. SSIDs can be set to auto-join by being manually connected to in Settings → Wi-Fi in the past (the default is auto-join and you can tap the ⓘ to disable auto-join) or because of a profile installed on the device potentially by your carrier or workplace (accessed through Settings → General → Profiles).

You also might need to clean out the check mark to remember networks if you sync settings over iCloud. When one device remembers a network - it will sync to all devices and computers.

  • I don't see any networks in Settings -> General -> Profiles – Jens Oct 13 '16 at 20:44
  • I don't find any list of settings that the carrier has set up but you are right that they are added by the carrier. Is there a way to see the list of those wifis and to prevent from connecting to those wifis that are deployed by the carrier? – Jens Oct 13 '16 at 20:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .