4

I'm a developer and it's possible to use BTLE to determine the proximity of a device from another.

  • Is there any way to get only one device to ring when they are all adjacent to each other?

For example, if I at the gym with my watch, connected to Wifi, it makes sense the watch would ring.

However, when I'm on the computer, charging my phone via USB, and wearing the watch, it makes no sense that all 3 devices would ring simultaneously. Furthermore, when I pick up a call on the iPhone, my apple watch kept ringing... while I was holding the phone to my ear!!

I do like this feature of "follow me calling", but need to fine tune it a bit. Is there any way to adjust it?

  • 1
    now that, is very annoying! – OzzieSpin Oct 9 '16 at 15:08
5

As of watchOS 3, iOS 10, and macOS 10.12 Sierra, this is not possible, and the simultaneous rings are rather comical, if not downright annoying. What I did was:

  • Disable the Ringtone in the FaceTime app on my iMac (set it to None under Preferences in OS X El Capitan, or disable Sounds for FaceTime under System PreferencesNotifications in macOS Sierra)
  • Assign a blank Ringtone on my iPad (set this in the Settings app under Sounds—this requires creating or downloading a custom ringtone)
  • Disable Sound for the Phone app on my WATCH (from the Watch app on your iPhone)

My reasoning is that the only times I'm going to pick up a call on any device other than my iPhone is when I'm already using my iMac or iPad, but not carrying my iPhone with me. In those cases, the onscreen notification is sufficient. It's very rare that I'm near my iMac/iPad and not using either of them, yet too far from my iPhone to hear it ring. Those rare cases do not seem to fall under your use case.

This is not a perfect solution, but at least it will keep you from being bothered by ringtones that keep going off while you're already answering the call. The WATCH might keep tapping you for a second, but that isn't nearly as distracting when you're trying to talk to someone.

  • 2
    This is a great workaround, I would add though that submitting feedback to Apple about this would be a step towards actually solving the issue, rather than having to work around it. apple.com/feedback – Mr Rabbit Oct 14 '16 at 14:25
2

On the iPhone - in the settings app - Phone section, turn off Calls on Other Devices. That turns off calls and SMS to other linked devices.

If you want to re-enable one device or two, you can then toggle them on piecemeal until you find the configuration that works best for you and also know how to change it going forward instead of just enabling it everywhere on all the devices.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .