14

After logging on, I see this dialog box pop up. Whenever I dismiss it, it reappears 30 seconds later. (Stealing focus at the same time! Grrrr!)

There was a problem connecting to the server "Slate".

"Slate" is my old iMac, which is sitting on the desk next to me, turned off. How can I stop my new Mac from constantly trying to connect to my old one? Both are running 10.7.1.

  • 1
    Did you set up a shortcut to automatically mount the drive? Looking in System Preferences > Users and Groups > Login Items. Or, is there an application/document that's automatically loaded on launch that points to the iMac? – chrismanderson Sep 21 '11 at 23:31
  • @ChrisAnderson: No, nothing that I can see. Is there any way to detect which application is responsible for connecting? – Brant Bobby Sep 21 '11 at 23:39
  • 1
    Nothing specific that I know of. I'd just check the Console if you haven't already, possibly you can find the error there. – chrismanderson Sep 21 '11 at 23:42
  • 4
    Possible duplicate of Endlessly repeating "There was a problem connecting..." error – joshfindit Jun 19 '18 at 18:37
  • @joshfindit This question appears to be the older and more vibrant question. Shouldn't that be flagged as a duplicate of this? – JMY1000 Jun 20 '18 at 4:39
9

Check System Preferences>Accounts>Login Items to see if there is a disk that is supposed to mount when you login. Make sure you check all of the user accounts.

  • Good idea, in my case (6 years later) does not apply. – Andrew Wolfe May 14 '17 at 13:39
3

I'm pretty sure this was happening because when I logged out, I was running an app which was located on the other computer.

I logged off and unchecked the "Reopen windows when logging back in" box, which stopped Lion from trying to reopen the app the next time I logged in.

Log Out dialog

  • 4
    Good answer. But one pro tip: If something like this happens again, use lsof from Terminal. That is a Unix tool to show you the list of open processes. And if you run it like this sudo lsof | grep Slate the output of lsof gets filtered through grep and you could then see exactly what application/process. Is attempting to use Slate. – JakeGould Oct 10 '14 at 2:38
2

I suspect you are connecting to a legacy file server as described in the kbase article below.

http://support.apple.com/kb/HT4700

We saw similar pop ups but clearing up our mounts addressed the issue.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • I managed to eliminate it by adding a folder from the named server to the "login items" and then deleting it. Weird, but it worked for me. Hope it helps. – user68842 Jan 28 '14 at 16:42
  • I had exactly the same problem, with my new Macbook continuously attempting to reconnect with my old Macbook which I had at one time connected to through the same wifi network. A similar alert would appear on my screen once every few minutes or so. I followed the above directions as far as "Looking in System Preferences > Users and Groups > Login Items." Then I clicked the lock icon in the bottom left corner of the window and entered my password to enable changes. I then clicked on the Guest User icon which appeared directly under my Admin Icon. In the new window I clicked to disable "Allow gu – user68887 Jan 29 '14 at 2:44
  • I had this problem as well; at login my Mac (iMac running 10.7) was trying to connect to an old Windows Home Server that I have removed. I found that there was a .../Login Items entry that was trying to mount a volume from that old server. Deleting that entry solved the problem. Thanks for the tip. – ifdefmoose Feb 22 '14 at 20:08
  • I found a similar issue with teacher computers trying to connect to an obsolete server. I found the auto-connect file(s) in MacintoshHD/Users/Shared. Then I deleted them. Problem gone! – user90394 Sep 11 '14 at 21:41
  • But how did you find the auto-connect files, Marie? – user99031 Nov 3 '14 at 21:59
1

This error typically comes up when OSX is trying to access a file or folder on a remote server, but it cannot connect to that server.

I have two examples to give an idea of where this can come from:

  1. You are able to have OSX connect to a remote folder automatically at login. Typically these are shown in the "Login Items" tab of the "Users & Groups" pref pane

    Example of an automatically-connected Folder on an AFP server

  2. When an application attempts to open a file that's on a remote server, OSX automatically tries to connect to that server in order to access the file.

    For example: If the music in your iTunes library is on a mounted network drive, and you have not connected the drive yet, playing a track will delay while it connects the drive and then iTunes will play the track.

In both cases, if the server where these files are located cannot be found, that error will come up.

Full disclosure: this was originally my answer to Endlessly repeating "There was a problem connecting..." error. That question has been marked as a duplicate of this one.

  • Spot on in my case. – shiri Aug 3 at 2:20

You must log in to answer this question.

protected by Community Feb 17 '15 at 19:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .