0

I just reinstalled Mac OS Sierra on my iMac, but Safari doesn't save any Preferences.

When Safari starts it prompts me to "enable Microsoft Silverlight plugin" (because Netflix demands this plugin). When I try to enable it (in Safari->Preferences->Security->Plugin Settings and check the Silverlight box and click Done), and then restart Safari, it hasn't saved, and the same prompt comes up and when I look, that setting I just checked is no longer checked.

This also happens when I try to change any other settings in Safari Preferences, as well. Nothing gets saved after I restart Safari.

Also, any changes made to the top menu bar of Safari aren't saved (by right clicking on it and choosing "Customize Toolbar", then adding the Cloud Tabs button, and removing the "share" button, for example).

Plz help!

UPDATE: I've tried this: https://discussions.apple.com/thread/7561960?start=0&tstart=0 which I thought was the problem, but this appears not to be the case. My ~/Library/Preferences/com.apple.Safari.plist file is unlocked and I "can read and write" to it, at least according to Finder. Still trying to fix this whole issue...

1

Ok, I fixed it by deleting all files with "Safari" in the name in the ~/Library/Caches folder and then emptying the trash. The bottom-most post on this page helped me: https://discussions.apple.com/thread/7604923?start=0&tstart=0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .