Clarification: There were two accounts on this macbook air (plus guest): Account A (Admin) Account B (standard)

1) After restarting after the latest macOS update, Account A was missing from the startup screen (Account B and Guest are the only options).

2) After a successful login to Account B, instead of starting macOS as usual, another startup screen appears, now with the option to log in as either Account A or Guest.

3) After logging in to Account A, macOS appears to run normally. Checking in Users & Groups, shows that Account A is still Admin. Account B is not listed.

4) Logging out of Account A returns to a screen with the option to log in again as either Account A or Guest.

5) A restart brings us back to #1, where we have to sign in first as Account B, then Account A.

Attempting to reinstall macOS from recovery mode prompts for the password from Account B (not the admin account) to unlock the HD.

What is going on, and how can it be fixed?

Original post:

The first time I restarted my macbook air after the latest macOS update, the primary user account had disappeared from the startup screen. My wife's account (a standard account which she never uses) and the guest account (which is apparently now a special browser only mode) are now the only options.

All attempts to login through my wife's account have failed. I figure she doesn't remember her password. I decided that I'm just going to try reinstalling the OS. So I restarted while pressing cmd-r to get into the recovery mode with macOS utilities and click to reinstall macOS.

Then it gets weird... My password didn't work to unlock the HD, and based on the hint, the hard drive is now encrypted under my wife's password instead of the one from my (now disappeared) admin account.

How/why would the primary account seem to disappear? And how did it end up treating a non-admin account as admin (and encrypting the HD under that password)? Did it just default to whatever other account it could find when the primary one went away?

And how can I get back in again? I imagine that all of the files are still there if I could access them.

Edit: My wife managed to remember her password and typed it in from the login screen, but instead of logging her in, it started another startup screen, now with options to log in as the primary account (the one that was missing before) or guest account, but now her account is missing. If I log out, her account is still missing.

But when I restart, it goes back to only having her account and guest as options... Then when I attempt to log in as her, it again takes me to a start up screen where the option are my account and guest.

What is going on here? Should I try to reinstall the OS?

  • Did you have FireVault on? This may matter in this case.
    – bret7600
    Oct 7, 2016 at 14:35
  • To reset the password for a user in recovery mode, and to keep data, you may type ‘resetpassword‘ into the terminal which can be found by clicking on the top menu under utilities.
    – bret7600
    Oct 7, 2016 at 14:38
  • Not the same as not having an admin account. See edits for an update. Once I log in to the admin account (which is possible only after entering the password for the other account), I can see in Users & Groups that it is still an admin account. Furthermore, the non-admin account (for which I still must enter the password when the computer restarts) is not listed.
    – Andy C
    Oct 7, 2016 at 15:00
  • Maybe try creating a third account and/or removing the guest account and see if it resolves itself...
    – bret7600
    Oct 7, 2016 at 16:45

2 Answers 2


This can happen when some users are not FileVault Enabled. Log in with another user and then check out security system preferences.

Thanks for the help, @bret7600. FileVault pointed me in the right direction; the solution was the same as here User account doesn't appear on first login screen I also had to recreate the other account (Account B) which showed up on first login screen but not in User & Groups to get everything back to normal.


I had a similar issue with no FileVault enabled and only one User that disappeared after 10.12.3 update (from 10.12.2). Nothing worked apart reinstalling 10.12.3 from USB without erasing the disk. This worked.

Not the answer you're looking for? Browse other questions tagged .