0

I have multiple JDKs installed. For one particular JNLP I need to make sure it is run with some older JRE. The Java Control Panel only recognises the latest version. How do I make it see the others and use them?

ls /Library/Java/JavaVirtualMachines/
1.6.0.jdk       jdk1.7.0_80.jdk     jdk1.8.0_102.jdk    jdk1.8.0_71.jdk     jdk1.8.0_92.jdk
  • Related: Starting Java Webstart App with older installed JRE Version. Try this answer. If it doesn't work please report back. – klanomath Oct 7 '16 at 15:22
  • No, the problem is that javaws does not find the java executable. It turns out that if I use the java 1.6 macaws it works, but there is no way to specify a java 1.7 JRE still. – simon Oct 10 '16 at 7:19
  • Is the jnlp available? Or is it some commercial/internal app? – klanomath Oct 10 '16 at 7:22
  • It's commercial/internal, yes, unfortunately. But It seems to me that the problem is more on the client side of things. – simon Oct 10 '16 at 10:52

You must log in to answer this question.

Browse other questions tagged .