6

Alright about a week and a half ago my Macbook Pro started acting up. All of my applications were crashing randomly and what not so I decided to just try and reinstall El Capitan onto it. I tried and tried and tried but only got an error about how it couldn't be installed on that computer.

So then I went and completely reformatted my hard drive and booted up with Internet Recovery. Told it to install Mac OS X Lion again (that's what came with my computer) and I am now getting the following errors when I look at the installer log:

Line 1: Install Mac OS X Lion [379]: Chunk validation failed, retrying...

Line 2: Failed to verify InsallESD.dmg: hdiutil verify failed

Line 3: Damaged resume data :/Volumes/Samsung SSD 850 EVO 250GB Media/Mac OS X Install Data/InstallESD.dmg.partial : /Volumes/Samsung SSD 850 EVO 250GB Media/Mac OS X Install Data/InstallESD.chunklist.partial

I'm leaning towards the conclusion that my SSD has gone bad even though it's only a little over a year old.

However, I thought I would post here too in case anyone else has had this problem and was able to fix it without getting a new hard drive.

It's also worth noting that when I use Disk Utility to check the disc for errors it doesn't find anything.

UPDATE

I just tried to install onto my old mac hard drive and I'm getting the same error. After some more research I saw that some say if you upgraded ram to take out the ram from one of the slots and try again. I'm going to try that when I get home and see if that works.

2 Answers 2

4

Pulling one of the RAM sticks out before trying to reinstall the OS did the trick for me!

When I first bought my MacBook 5 years ago it only came with 4GB of RAM. About a year and a half ago I upgraded this to 8GB. For whatever reason this throws errors and won't let you reinstall Mac OS X again.

So what I did was turned the MacBook off and flipped it over and took off the bottom cover. I then removed one of the sticks of RAM (the one on top) and restarted the computer and tried installing again. This time it installed without any issues and after it was installed I put the other stick of RAM back in again.

Below is a link to an Apple Support article detailing how to remove RAM from a MacBook Pro.

MacBook Pro: How to remove or install memory

9
  • 2
    I have been trying, usb boot, internet download, but with no luck for days. Thank you so much. I would have never guessed it was the upgrading of the RAM causing this. The installation got through this time with no problems. Thank you again for pointing me to the right direction.
    – Ayoub
    Commented Aug 27, 2017 at 12:39
  • @Ayoub No problem! Glad I was able to help! :)
    – Dev 404
    Commented Aug 28, 2017 at 17:12
  • I really did not think this would work but it did - cheers!!! Commented Feb 7, 2019 at 21:39
  • A bit unfortunate that you wiped your ssd before finding this, but better late then never!
    – Sam
    Commented Feb 7, 2019 at 21:44
  • 1
    @scarpaz Sorry to hear that. Please report back here with an answer if you find another solution.
    – Dev 404
    Commented Feb 16, 2022 at 18:38
1

I had this same issue on a MacBookPro9,2 and I tracked down the problem to a defective SATA controller on the motherboard. Apparently the SATA controller fails commonly on 2012 MacBooks. The Internet Recovery install process downloads chunks of the install packages to a staging area on the target volume, and if you have a faulty SATA controller that writes corrupted data, it's common to have chunks that don't pass validation after being written to disk.

I managed to get past the specific hdiutil verify failed error by using the Disk Utility and restoring the installation DMG image onto a USB memory stick, then performing the OS installation from the memory stick. When running the installation from a USB drive without connection to a wi-fi rather than performing an Internet Recovery, the installer won't try to re-download packages if they fail verification, and just moves on.

Prior to the SATA diagnosis, I also tried to pull back the date and remove one of the two 4GB memory SODIMMs, but neither had an impact on the error.

So, if others need a manner to get past this specific error (at their own risk), they key is to switch from an Internet Recovery install to a regular USB install.

In my case, the install log would still contain verification failures and the final install was still corrupted because of the faulty SATA controller, and the issue was finally remedied by moving the disk to an external USB enclosure and installing the OS there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .