6

After updating my iPhone 6 to iOS 10, all calls coming from Viber and Skype are appearing in the calls list as normal phone calls. Also, when I'm on a Viber call and a real phone call comes, I don't get notified. Before iOS 10 it used to mute Viber and give me a notification than someone is calling. How do I return back to these settings?

3

EDIT: I messed up and this is an article from an ios10 preview version. This setting seems to not exist anymore. So as far as I know, reverting to the old way is not possible :/


This change is due to Viber and Skype now using CallKit which you can read up on here.

In that article it says this:

It’s important to note that Apple won’t force you to let any VoIP app integrate with Phone without your permission. Just like you must authorize third-party apps to access your camera or microphone, CallKit-enabled apps will put up a new type of iOS prompt at first run asking for permission to use CallKit.

Makes perfect sense in my eyes. A little further down they say this:

Any VoIP apps that you’ve permitted to use CallKit will honor your current Do Not Disturb setting and a list of blocked contacts. Lastly, you can revoke these permissions for VoIP apps by flipping switches in Settings → Phone → Service Providers.

So going to Service Providers and disabling access to CallKit should revert it back to the way you want.

  • I can't find Service Providers under settings -> phone – Amr Elgarhy Oct 6 '16 at 12:54
  • @AmrElgarhy hmm seems you are right, I can't seem to find them on my phone either. But I don't see why that setting would not exist, ill try poking around more and let you know. – Hoi_A Oct 6 '16 at 13:01
  • @AmrElgarhy I quickly installed skype and it seems like apple removed the whole "apps need permission to use CallKit" after ios10 beta 3, the article I linked and quoted happens to be from before that change, so my bad, I guess I should check better next time. However this now leads me to believe that it's not possible to revert back to the old way. – Hoi_A Oct 6 '16 at 13:12
  • that's really bad from apple to do such thing, it is really an annoying feature – Amr Elgarhy Oct 6 '16 at 13:14
3

I don't think it is possible to revert back to old settings now. I have opened a ticket with apple to get the users freedom to either use or not use. The setting like Setting -> Phone -> Service provider makes perfect sense. Lets see if apple provides this capabilities or not.

1

At least for Skype you can disable callkit integration by opening the Skype app and going to "My info" -> Settings -> disable "Integrated calling".

1

This problem has been solved automatically, I am not sure if it is because of IOS 10.1.1 or an update to viber app, currently it gives me a waiting beep/screen while I am on viber call and getting a normal call, didn't test yet with other apps like skype/whatsapp

-3

In IOS 8.0.1, call logs can be deleted for everyone in viber, after that you wont be able to see calls or messages that has been made :)

  • 1
    That unfortunately tells us nothing of how it works in iOS 10. – Tetsujin Mar 2 '17 at 12:03

You must log in to answer this question.

protected by bmike Jun 26 '17 at 17:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .