0

To debug configd it is suggested by man page to run it using

$ usr/libexec/configd -d 

And you would kill it before launching it using SIGTERM otherwise it will launch again as follows:

$ sudo killall -SIGTERM configd     

From man page of configd

 SIGNALS
 configd was designed to run without any intervention but if you insist on sending a signal to the dae-mon daemon
 mon then the following are available:

 SIGHUP   This signal, typically used to tell a daemon to reload its configuration, is ignored (there is
          no configuration).

 SIGTERM  This signal initiates a "graceful" shutdown of the daemon.

Problem is that SIGTERM is not gracefully killing configd. It is restarting right back up. Do you guys know any solution?

I also tried killing launchctl

$ sudo launchctl unload /System/Library/LaunchDaemons/com.apple.configd.plist
Password:
/System/Library/LaunchDaemons/com.apple.configd.plist: Operation not permitted while System Integrity Protection is engaged

Also tried to disable system integrity protection for testing but failed:

$ sudo csrutil disable
csrutil: failed to modify system integrity configuration. This tool needs to be executed from the Recovery OS.

My platform

$ sw_vers 
ProductName:    Mac OS X
ProductVersion: 10.11.6
BuildVersion:   15G1004
1

You can't turn off SIP on a running macOS system. You need to boot into the Recovery partition and run the csrutil command. This page at Macworld details the steps nicely.

  1. Restart your Mac.
  2. Before OS X starts up, hold down Command-R and keep it held down until you see an Apple icon and a progress bar. Release. This boots you into Recovery.
  3. From the Utilities menu, select Terminal. At the prompt type exactly the following and then press Return: csrutil disable

  4. Terminal should display a message that SIP was disabled.

  5. From the  menu, select Restart.

You can re-enable SIP by following the above steps, but using csrutil enable instead.

  • This is not really what i asked. This should be more of a comment. – PnotNP Oct 5 '16 at 23:42
  • You need to stop SIP before you can kill launchctl, which is something you need to do to keep troubleshooting. – IconDaemon Oct 5 '16 at 23:51
  • I googled that error code and found the steps to disable SIP. But my question is there any other way without restarting it. Why is configd not getting killed gracefully. – PnotNP Oct 6 '16 at 0:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .