Loaded macOS Sierra this morning. Now, once VMWare is running, cmd+tab switches me back to the mac environment but system immediately and automatically switches me back to vm. Result? Can't access mac environment when vm is running. Help?


Force quit Dock from Activity Monitor. Dock automatically restarts, and Cmnd+Tab should now work. Some glitch with Dock, it seems. Worked for me.

| improve this answer | |

In my case, I wasn't even able to open the Activity Monitor (or the Launchpad)

I had to use the terminal to kill the Dock process, it restarted automatically after a few seconds

In the terminal, type: ps aux | grep -i dock

Note the PID (2nd column) of the process named: "/System/Library/CoreServices/Dock.app/Contents/MacOS/Dock"

Kill that process: kill pid. E.g. if the PID was 708, run kill 708

| improve this answer | |
  • Is there a reason these steps are preferred over killall Dock? – grg Nov 3 '17 at 8:32
  • 1
    @grgarside No reason specifically. I tend to avoid killall in general - but I guess that would work too. – muya_ Nov 3 '17 at 11:32
  • Sometimes you have to kill -9 the pid for this to work. – Jason D Oct 5 '18 at 17:23
  • 1
    recommend ps aux | grep -i dock | grep -v docker if you're a developer and might have a ton of docker related processes running. – BSpiros Jul 15 at 21:17

Apparently, Sierra set the keyboard preference to a loop. Turned that off and everything worked as usual. (Detailed path: system preferences>keyboard>shortcuts>input sources) Both boxes were checked. I unchecked both.

| improve this answer | |
  • 1
    I don't understand. What was the problem? Could you elaborate how or why your solution fixes the problem? – jvriesem Nov 27 '17 at 4:56

I have found that when you're running a Virtual Machine manager like VirtualBox sometimes an open Virtual Machine window can grab the key (which is often used switch between VM keyboard capture mode).

In this case you can fix it by bring the VirtualBox Console window up (e.g. using the Dock bar icon) and tap the key again and it should release it properly. With VMWare the settings may be different but it's worth looking at the keyboard capture/mapping options to see if a similar thing is happening.

| improve this answer | |

Launch Activity monitor, then select user tasks, and shut down the process called 'dock'. This worked like a charm for me. Problem solved, instantly. Well, it took about ten seconds while the dock rebooted itself, then command tab worked like a charm as usual, no restart needed.

| improve this answer | |
  • 2
    Instead of replicating an existing answer please upvote the one which helped you. – nohillside Dec 4 '17 at 5:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .