5

I've disabled SIP and tried to install rEFInd on my MacBook, which is not partitioned in any way by boot camp and is one single drive. The install of rEFInd says it is installing to /Volumes/ESP for the EFI boot and completes successfully. After rebooting, however, rEFInd menu does not come up when holding option key or anything. How do I get that installed so that it is usable?

  • Currently I am running El Capitan with Linux dual boot. I would like to know if it is feasible the upgrade as well. – coffekid Oct 5 '16 at 20:17
1

After reading through the refind-install script (at version 0.10.4), I discovered that all I needed to do was make sure that the EFI partition was mounted.

  1. From the terminal, run diskutil list to find the EFI partition. In my case this was /dev/disk0s1.
  2. Mount the EFI partition from the location identified in step 1. For me this was mount /dev/disk0s1
  3. Run the rEFInd install script (from the unzipped rEFInd directory): sudo ./refind-install

I got friendly output in my terminal: Installation has completed successfully. After this rEFInd worked on my MacBook Pro.

  • I get mount: /dev/disk0s1: unknown special file or file system. – özg Jan 27 '18 at 19:00
  • 1
    @özg Try mount -t msdos /dev/disk0s1 /Volumes/ESP, the latter directory must exist. – greuze Feb 14 '18 at 16:04
  • OP, refind-install already mount the partition, so there is no necessary manual mounting. – greuze Feb 14 '18 at 16:05
0

Not sure if this means anything to you as I had rEFInd previously installed and not a fresh install as you are, but quick story so far I had rEFInd installed from the Yosemite days for dual boot OSX and KALI Linux, then updated to El Capitan and had to go back over a few of the steps to get it running again(cant remember which parts).

I then upgraded to Sierra and thought I had lost rEFInd as I could not mount /Volumes/ESP. Running 'diskutil list' to me it looks like its now called EFI so mounted which on my machine was disk0s1 so 'diskutil mount disk0s1' allowed me to find the lost rEFInd files.

Refollowing the steps on the excellant website 'http://www.rodsbooks.com/refind/installing.html' with regards to 'Installing Manually using MAC OSX' I downloaded the latest version of rEFInd, replaced the old refind folder on the mounted EFI volume with the new, got rid of all 32bit and ARM files as to me they were not required for my 64bit machine (again as per instructions).

With regards to the 'bless' part I renamed ESP to EFI and added in another rEFInd folder path so it now read as

'sudo bless --mount /Volumes/EFI --setBoot --file /Volumes/EFI/efi/refind/refind/refind_x64.efi --shortform'

On reboot the rEFInd bootload is now replacing the started MAC bootload and is giving me the dual option back.

To be honest holding 'option key' during boot allowed me to find the rEFInd bootloader, but I never put 2 and 2 together as per the change from ESP to EFI.

The only thing is the GRUB loader for KALI is no longer working as it used to. Like I say not sure if this means anything to your setup as it a fresh install, but for previously installed rEFInd it worked for me.

  • There is no need to hold ALT key down on boot. rEFInd replaces the standard boot with another menu of its own. so if its working you should see the rEFInd menu – pilch Nov 3 '16 at 11:05
  • cont.. see the rEFInd boot menu without pressing any key options. However if things go wrong and you get stuck you can always fall back on holding the ALT key to divert to the Macs default boot menu. Anyways Hope you have managed to get it working by now. – pilch Nov 3 '16 at 11:07
0

Not sure if bless is a great way since they warn against it in many places. Anyway what worked for me was using the Recovery Mode with rEFind on a USB drive as given here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .