0

Mac Mini (Mid-2011), 16GB SSD, 16GB RAM, El Capitan (v10.11.6)

The Mac ran fine until I upgraded to Sierra. The latest Mac OS conflicted with most of the specialized apps I use every day, So I immediately returned to El Capitan.

Activity monitor shows that two "Installer/Installer.app" items are always running and are they major users of all of my available memory. Consequently, all my others apps become unresponsive. I run Disk Utility, and the Installer.app show up there as .dmg files; but I cannot erase, delete, or unmount them. None of my 3rd party app can remove the installers.

My Mac Mini, which should be running super-fast (as it used to), now runs dreadfully and disgustingly slow. I a truly upset with Apple for this kind of garbage. To get their help: $$$.

  • 1
    "I immediately returned to El Cap" ... How? Clean install + Time Machine? – Tetsujin Oct 5 '16 at 16:39
  • You're sure it is the El Capitan installer? It sounds much more like a virus to me, given that the El Capitan installer is an app, not a disk image. – tubedogg Oct 5 '16 at 18:24
  • You're upset with Apple that your 5-year old Mac Mini is slower with a brand-new OS and you call it garbage? You know the apps you 'use every day' don't work with Sierra yet you upgraded anyway? Um...ok. – fsb Oct 5 '16 at 18:47
  • • I am certain it is the installer; not a virus. The installer is an app that can be seen, but not accessed or deleted–not by my software. I verified that it resides on at "Installer/Installer.app." The installer.app will show up in Disk Utilities, but cannot be eject or unmounted. Thank you sincerely for your response! – VGM Oct 5 '16 at 19:44
  • • I did not say I was upset with Apple about my Mac Mini. I am unhappy that this installer.app situation found its way onto my computer–that's the garbage. With a 500GB SSD (not 16GB as previous stated) & 16GB RAM, my Mac Mini is anything but slow. Mac computers and I have been together since they first appeared, and I use nothing else. Appreciate your comment. – VGM Oct 5 '16 at 19:55
2

Double click the process in activity monitor and look for the Open Files tab. This should give you an idea where the process is coming from

Try to force-quit the process in activity monitor.

Then try to delete the dmg files (make sure they are unmounted, right-click > unmount on the dmg).

-3

Installer was eating up all my memory. The following worked for me.

Main menu: GO Go to Folder: Copy and paste the following line:

~/Library/LaunchAgents

Delete anything that is in that folder. Shut down. Restart.

  • 1
    You may easily delete way too much that way. – nohillside Dec 19 '16 at 8:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .