4

After upgrading to Sierra, The option to add a webpage to the default “Bookmarks Folder” of Safari has disappeared. I’m given the option to bookmark a webpage to my Favorites folder, as well as all of my custom folders, but I no longer have the option to bookmark to “Bookmarks.” The Bookmark folder still exists, along with my previous bookmarks within it, but the option to add to it has disappeared from the UI:

enter image description here

In as many previous OSX’s as I can recall, “Bookmarks” existed as an option to bookmark a webpage to. Now it’s gone. I’ve added a “Bookmarks 2.0” folder in the meantime to save webpages to.

I’ve cleared my cache & local data, tried disabling extensions, purged Safari’s Container + Saved Application State folder contents, and traversed all of Safari’s preferences to see if I’d overlooked something. Additionally, I’ve reset iCloud syncing (unchecked then rechecked System Preferences > iCloud > Safari).

Nothing has worked. What gives?!


If there’s any confusion, SE member tubedogg posted a screenshot of the default configuration I’m talking about in the comment section. Many thanks :)

enter image description here

enter image description here

  • After creating a (new) "Bookmarks" folder in an almost vanilla Sierra/Safari I have no problems to save bookmarks to it. Neither a vanilla Sierra nor an El Capitan provides a default bookmarks folder named "Bookmarks"... Probably something wrong with the bookmarks.plist. – klanomath Oct 5 '16 at 9:10
  • 2
    @klanomath Here are screenshots of what the OP means: imgur.com/a/glQ2X (from El Capitan). The item named "Bookmarks" in the first screenshot is not really a folder (despite its icon), it is the top-level container inside which Favorites, the Bookmarks Menu, and all other bookmarks live. In the second screenshot, the Akihabara bookmark appeared at that location after selecting the Bookmarks "folder" from the first screenshot. The OP wants to save bookmarks so they are at the same level as Favorites, Bookmarks 2.0, etc. from his screenshot, instead of inside a folder. – tubedogg Oct 5 '16 at 19:07
  • njboot, if you open Edit Bookmarks, can you drag items into place so they are top-level alongside Favorites, or can only folders now appear there? – tubedogg Oct 5 '16 at 19:10
  • @tubedogg yes i can. i still have a bunch of individual bookmarks at the top level, it’s just that the option to add to the top level has disappeared. – njboot Oct 7 '16 at 10:24
  • @njboot My answer below is only a workaround. This seems like a bug that you should report to Apple. – kccricket Oct 14 '16 at 12:47
4

One potential workaround:

Open the bookmarks sidebar using the "Sidebar" icon in the toolbar or the "Show Bookmarks" menu item in the "Bookmarks" menu. Highlight the URL in the menu bar and drag it into the bookmarks sidebar.

  • Thanks, this is a great workaround. Unfortunately the underlying issue still persists :( – njboot Dec 13 '16 at 5:09
4
+50

This issue may be entirely unrelated to the OS. I'm having this issue too as of today and I haven't upgraded to Sierra. So I think it's actually the latest Safari update, 10.0, which was installed on my computer this morning, that is causing this bug.

Other people reporting the same issue, seems to be Safari 10.0 upgrade that is the issue. https://discussions.apple.com/thread/7680935?start=60&tstart=0

1

Oddly enough, when I right click on the + symbol in the address bar, I do have the option to add the page to my Bookmarks. Though it still isn’t appearing under the Bookmarks dropdown Menu, this is the easiest workaround I’ve found.

enter image description here

—————

enter image description here

  • Amazing. If you don't see the "circled plus" icon, note that it does not appear until you mouse over the address bar. At least this is the case in Safari 10.1.1 here. (My rant: This is another un-discoverable feature thanks to the awful Jonny Ives "Let's make everything thin, white, pastel, illegible or disappear" design philosophy!) Anyhow, it definitely works – Jerry Krinock Apr 13 '17 at 14:54
1

It took me awhile to resolve this issue.

  1. Export all your current bookmarks before doing anything.
  2. Go to a Mac with Bookmarks Menu working correctly.
  3. The bookmarks file is stored at ~/Library/Safari (or Command/Shift G & enter ~/Library/Safari).
  4. Copy bookmarks.plist to flash drive, Dropbox, etc and move to your desktop.
  5. Open ~/Library/Safari on your Mac, rename old bookmarks.plist, move it to your desktop
  6. Move the new bookmarks.plist from desktop to Safari folder.
  7. Close Safari if open.
  8. Open Safari to see new bookmarks.
  9. Remove new bookmarks in Safari and move your bookmarks into the correct place.
  10. This may take a little finessing.
  • Thanks, I'm going to try this. What's odd is I created another user account, thinking that if it were due to an issue with the .plist in my ~/Library it wouldn't exist outside of it. The same thing happens in a fresh test account though, which makes me doubt it's specific to my own account...but rather a global issue...I will give this a try when I get a chance though as this is driving me nuts! – njboot Mar 27 '17 at 2:39
0

To summarize:

• The *Bookmarks menu item in the Add this page to… popup in the Add Bookmark… was removed by Apple in Safari 10. The only way to get it back is to revert to an older version of Safari.

• The answer given by njboot on Dec 20 '16 is a good alternative.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .