15

I am having a bit of an issue here with the default mail application in mac OS El Capitan. I am using my gmail account on the mail client and it is autosaving drafts when I compose messages ... I have done some searching and found various answers saying that I can turn it off by going to Mail --> Preferences --> Accounts and after selecting the account in "Mailbox Behaviours" box just uncheck the "Store draft messages on the server" check box ... as explained in this tutorial that I have found How to Configure Apple Mail to Avoid Duplicate Drafts with Gmail ... But there is a issue ... I don't have that option in my preferences .. please see this screenshot of my preferences screen.

Preferences Screen

I am really confused on this ... Oh forgot to tell this is my first Mac experience. Looking forward to your answers. Thanks :)

UPDATE: I have upgraded to macOS Sierra ... but the issue still persists ...

15

After no one replied so I did some research on this again ... though I could not find how to turn off the autosave draft feature on my apple mail application ... I did figure out a way to deal with this annoying drafts problem ... All I did is that in "Mailbox Behaviors" tab I changed the location of the Drafts folder ... now instead of saving the drafts in Gmail/Drafts folder the mail application is saving them in a Local Drafts folder on my mac ... Life is much easier now ... now I don't have to see all those drafts when I open my mailbox on my smartphone.

enter image description here

You must log in to answer this question.

protected by Community Jan 31 '17 at 9:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .