1

I want to use AirDrop to transfer some photos from iPhone to my MacBook Pro (Retina, 15-inch, Mid 2014) running on OS X El Capitan 10.11.6. AirDrop requires both WiFi and Bluetooth to be turned on. But when I turn on Bluetooth, WiFi doesn't work, I get errors like:

This site can’t be reached

www.google.com took too long to respond.

I've found this very similar question, and I've tried some solutions from the answers but they didn't help me.

WiFi router is TP-LINK TL-WR740N Channel is set to Auto and WiFi mode is '11bgn mixed'.

I also use wireless mouse, I've tried to turn it off, it has no effect on network.

  • Is there a Bluetooth device (your iPhone or something else) that your computer is trying to get its internet from when you turn on Bluetooth? Check System Preferences > Network and if there's an item on the left named Bluetooth Pan, click on it then click the gear menu at the bottom and choose "Make Service Inactive". Also, when you turn on Bluetooth, check the Bluetooth menu on the right side of the menu bar and ensure nothing's connected that shouldn't be. – tubedogg Oct 4 '16 at 15:51
  • @tubedogg, The only device is my iPhone 6s. I tried both cases: turn bluetooth on iPhone on and off. And I have worked on another computer (iMac) with bluetooth keyboard and mouse and WiFi worked perfectly! The problem is in my Macbook, I'm sure. – kelin Oct 4 '16 at 20:51

You must log in to answer this question.

Browse other questions tagged .