1

I having a issue with safari 10, (OSX 10.12.1), often one tab get unresponsive, and I can't even close it, but other tab and safari preferences are working fine.

No extension enabled, no plug in, cache cleared ... I don't know what to do.

Any idea how to fix this?

From Console I received this errors / alerts :

error   06:36:16.281404 +0100   parsecd network_config_has_proxies_configured network_config_has_proxies_configured is deprecated
error   06:36:16.281439 +0100   parsecd tcp_connection_get_remote API Misuse: Function must be called after tcp_connection_start
error   06:36:16.281497 +0100   parsecd tcp_connection_is_cellular API Misuse: Function must be called after tcp_connection_start
error   06:36:17.227946 +0100   WindowServer    _CGXRemoveWindowFromWindowMovementGroup: window 0x231 is not attached to window 0x237
error   06:37:35.051831 +0100   ScriptMonitor   Detected missing constraints for <private>.  It cannot be placed because there are not enough constraints to fully define the size and origin. Add the missing constraints, or set translatesAutoresizingMaskIntoConstraints=YES and constraints will be generated for you. If this view is laid out manually on macOS 10.12 and later, you may choose to not call [super layout] from your override. Set a breakpoint on DETECTED_MISSING_CONSTRAINTS to debug. This error will only be logged once.

Then a few minutes after I have

error   06:40:32.932710 +0100   com.apple.Safari.SearchHelper   LaunchServices: Database mapping failed, process cannot lookup com.apple.lsd.mapdb port by name.
error   06:40:32.934972 +0100   com.apple.Safari.SearchHelper   LaunchServices: disconnect event received for service <private>
error   06:40:32.934981 +0100   com.apple.Safari.SearchHelper   LaunchServices: Database mapping failed, process cannot lookup com.apple.lsd.mapdb port by name.
error   06:40:32.959468 +0100   parsecd keyboardInputMode property not set, using <private>
error   06:40:32.964640 +0100   com.apple.Safari.SearchHelper   LaunchServices: disconnect event received for service <private>
error   06:40:32.964657 +0100   com.apple.Safari.SearchHelper   LaunchServices: Database mapping failed, process cannot lookup com.apple.lsd.mapdb port by name.
error   06:40:32.966643 +0100   com.apple.Safari.SearchHelper   LaunchServices: disconnect event received for service <private>
error   06:40:32.966644 +0100   com.apple.Safari.SearchHelper   LaunchServices: Database mapping failed, process cannot lookup com.apple.lsd.mapdb port by name.
error   06:40:32.966887 +0100   com.apple.Safari.SearchHelper   LaunchServices: disconnect event received for service <private>
error   06:40:32.966895 +0100   com.apple.Safari.SearchHelper   LaunchServices: Database mapping failed, process cannot lookup com.apple.lsd.mapdb port by name.
error   06:40:33.013506 +0100   com.apple.Safari.SearchHelper   LaunchServices: disconnect event received for service <private>
error   06:40:33.013601 +0100   com.apple.Safari.SearchHelper   LaunchServices: Database mapping failed, process cannot lookup com.apple.lsd.mapdb port by name.
error   06:40:33.014192 +0100   com.apple.Safari.SearchHelper   LaunchServices: disconnect event received for service <private>
error   06:40:33.014212 +0100   com.apple.Safari.SearchHelper   LaunchServices: Database mapping failed, process cannot lookup com.apple.lsd.mapdb port by name.
error   06:40:33.014585 +0100   com.apple.Safari.SearchHelper   LaunchServices: Database mapping failed, process cannot lookup com.apple.lsd.mapdb port by name.

Tried to go on the developer menu and display the console, page source or anything, but the tab is unresponsive

Then I go on activity monitor and force quite : Safari Web Content (not Responding)

I think this could be an issue with the Nvidia Driver / OSX Sierra :

Safari Web Content details

wd
/System/Library/Frameworks/WebKit.framework/Versions/A/XPCServices/com.apple.WebKit.WebContent.xpc
txt
/System/Library/Frameworks/WebKit.framework/Versions/A/XPCServices/com.apple.WebKit.WebContent.xpc/Contents/MacOS/com.apple.WebKit.WebContent
txt
/System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebProcessShim.dylib
txt
/private/var/folders/hx/zfzqmnxs5yl0cm68pdkvvllh0000gn/C/com.apple.IntlDataCache.le.kbdx
txt
/private/var/db/mds/messages/se_SecurityMessages
txt
/usr/share/icu/icudt57l.dat
txt
/System/Library/CoreServices/SystemAppearance.bundle/Contents/Resources/SystemAppearance.car
txt
/System/Library/PrivateFrameworks/DataDetectorsCore.framework/Versions/A/PlugIns/PhoneNumbers.plugin/Versions/A/PhoneNumbers
txt
/private/var/folders/hx/zfzqmnxs5yl0cm68pdkvvllh0000gn/0/com.apple.LaunchServices-175-v2.csstore
txt
/System/Library/Keyboard Layouts/AppleKeyboardLayouts.bundle/Contents/Resources/AppleKeyboardLayouts-L.dat
txt
/usr/lib/libstdc++.6.0.9.dylib
txt
/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vImage.framework/Versions/A/Libraries/libCGInterfaces.dylib
txt
/private/var/folders/hx/zfzqmnxs5yl0cm68pdkvvllh0000gn/C/com.apple.Safari/ApplicationCache.db-shm
txt
/System/Library/Fonts/LastResort.ttf
txt
/System/Library/PrivateFrameworks/DataDetectorsCore.framework/Versions/A/PlugIns/PhoneNumbers.plugin/Versions/A/Resources/main.cache
txt
/System/Library/PrivateFrameworks/WebContentAnalysis.framework/Versions/A/WebContentAnalysis
txt
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/Resources/libFontRegistryUI.dylib
txt
/System/Library/Fonts/Times.dfont
txt
/private/var/folders/hx/zfzqmnxs5yl0cm68pdkvvllh0000gn/C/com.apple.WebKit.WebContent/com.apple.metal/NVIDIA GeForce GT 755M/functions8.data
txt
/private/var/folders/hx/zfzqmnxs5yl0cm68pdkvvllh0000gn/C/com.apple.WebKit.WebContent/com.apple.metal/libraries8.data
txt
/usr/lib/dyld
txt
/Users/kevinnadjarian/Library/Caches/com.apple.Safari/WebKitCache/Version 9/Blobs/27328DBD2B91C39D5238B5B2C7D670F90733B5C7
txt
/Users/kevinnadjarian/Library/Caches/com.apple.Safari/WebKitCache/Version 9/Blobs/ED1AFC2B35929583F40975B0A4F996768FD902CC
txt
/System/Library/Fonts/HelveticaNeue.dfont
txt
/System/Library/Fonts/Helvetica.dfont
txt
/System/Library/Fonts/LucidaGrande.ttc
txt
/Library/Fonts/Arial.ttf
txt
/Library/Fonts/Arial Italic.ttf
txt
/Library/Fonts/Arial Bold.ttf
txt
/Library/Fonts/Arial Bold Italic.ttf
txt
/System/Library/Fonts/PingFang.ttc
txt
/System/Library/Fonts/SFNSText.ttf
txt
/private/var/db/dyld/dyld_shared_cache_x86_64h
0
/dev/null
1
/dev/null
2
/dev/null
3
FNetwork.defaultStorageSession
5
/private/var/folders/hx/zfzqmnxs5yl0cm68pdkvvllh0000gn/C/com.apple.Safari/ApplicationCache.db
6
/private/var/folders/hx/zfzqmnxs5yl0cm68pdkvvllh0000gn/C/com.apple.Safari/ApplicationCache.db-wal
7
/private/var/folders/hx/zfzqmnxs5yl0cm68pdkvvllh0000gn/C/com.apple.Safari/ApplicationCache.db-shm
8
/System/Library/Extensions/GeForceMTLDriver.bundle/Contents/Resources/internal.metallib
9
/System/Library/Frameworks/QuartzCore.framework/Versions/A/Resources/default.metallib
10
/private/var/folders/hx/zfzqmnxs5yl0cm68pdkvvllh0000gn/C/com.apple.WebKit.WebContent/com.apple.metal/NVIDIA GeForce GT 755M/functions8.maps
11
/private/var/folders/hx/zfzqmnxs5yl0cm68pdkvvllh0000gn/C/com.apple.WebKit.WebContent/com.apple.metal/NVIDIA GeForce GT 755M/functions8.data
12
/private/var/folders/hx/zfzqmnxs5yl0cm68pdkvvllh0000gn/C/com.apple.WebKit.WebContent/com.apple.metal/libraries8.maps
13
/private/var/folders/hx/zfzqmnxs5yl0cm68pdkvvllh0000gn/C/com.apple.WebKit.WebContent/com.apple.metal/libraries8.data
  • When this happens again, look in Console for any Safari errors and update your question with that text. The way your question is currently written makes it very difficult to determine what the problem is. – fsb Oct 4 '16 at 14:44
  • Updated with console errors / alerts – Kevin Oct 5 '16 at 5:43
  • @KevinCork, I have the exact same problem. Already removed almost all content under my ~/ with find .|grep Safari. Re-configured Safari. Still the same. I've noticed this behavior on github.com and some other sites, notably bitbucket.org. Not sure why these sites. Again, Chrome opens this sites without any problem. – sevenfourk Oct 7 '16 at 15:37
  • now I see why many people using Chrome on mac, even Safari has very nice design, still glitches occur time to time. – sevenfourk Oct 7 '16 at 15:42
  • I read it could be because of the Nvidia driver, still having the issue , tried a few thing too but no luck – Kevin Oct 7 '16 at 15:45

You must log in to answer this question.

Browse other questions tagged .