3

Today I had changed my MacBook Pro early 2011 hard drive for a SSD, and did a clean installation of macOS Sierra. Everything is working like a charm, except for the Mission Control, when I try to execute it via Trackpad shortcut or App in the Launchpad, it restarts me the Dock. That is an unexpected issue, and I'm want to know if someone encountered this bug before!

4

I had a similar problem with a Mac Book Pro (late 2011). I did a clean installation of macOS Sierra and Mission Control and Launchpad were not working, but it did not restart the Dock when I tried to open any of them. I researched a bit I tried killall Dock on the Terminal, for restarting it manually and that worked for me.

Give it a try. Maybe doing it manually will make it work.

  • I tried that too, but I't didn't worked, my Mac Book Pro is just same as yours, thanks anyway. – bretanac93 Oct 8 '16 at 12:22
  • Thanks, that just worked for me, upgrading from El Cap to Sierra on a late 2012 iMac. – joe Oct 31 '17 at 20:46
0

You can use a system "tweaking" utility such as OnyX.

The workflow is:

Parameters > Applications > Mission Control > Turn on Mission Control [checkbox]

It'll give you a warning that OnyX must reopen the Dock for this change to take effect."

Hit Continue and let it do it's business and... done. Functionality = instantly restored. Typing this takes 10x longer than actually doing it btw so no worries there. Painless. (But of course not entirely pain-free as you actually have to expend kilojoules and a couple seconds fixing something that shouldn't be broken in the first place but hey, working solution until base bug fixed. ; )

P.S. I'm on it.

  • Onyx worked for me on 2019-01-07 with MacOS 10.14.2. Thanks! – zajerao Jan 7 at 11:15
-1

Not sure if you are using Duet but I found that this was preventing Mission Control. Disable it and regain control of your missions...

-1

If you're using Duet (lets you use iPad as second screen) and you have this problem, instructions on fixing it are here:

https://help.duetdisplay.com/faq/124748-duet-was-running-and-i-got-logged-out-of-my-mac

  • 2
    I don't see how the OP's question has anything to do with Duet? – fsb Feb 25 '17 at 23:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .