2

I used to have AirPlay disabled using the terminal (sudo chmod 000 /System/Library/CoreServices/AirPlayUIAgent.app/Contents/MacOS/AirPlayUIAgent). I just upgraded to Sierra and now it has come back and the old way won't work anymore.

Any one know why? Or what else I can do?

  • What error do you get? – At0mic Oct 3 '16 at 13:28
  • I'd guess the old way probably doesn't work any more due to System Integrity Protection (though El Cap had that too, but maybe it's been strengthened further in Sierra). Not sure what the best solution is now, though. – calum_b Oct 3 '16 at 14:07
  • Just says operation not permitted. – VScape Oct 3 '16 at 16:07
1

@scottishwildcat is correct. Most of /System is off-limits to changes so long as System Integrity Protection (SIP) is enabled.

You can temporarily disable SIP by rebooting into Recovery Mode (press and hold Command-R from the time the computer starts until you see the Apple logo), then opening Terminal from the Utilities menu and entering this command:

csrutil disable

Reboot back into Recovery Mode and access the Terminal again. Enter your desired command, then enter this command to re-enable SIP:

csrutil enable

Reboot one more time into macOS as normal and AirPlayUIAgent should have the specified permissions. Note you'll likely need to redo this each time you upgrade macOS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .