1

I'm trying to install LastPass on a fresh OS install that has no browser but Safari. Clicking the Download link at lastpass.com sends me to the Safari Extension Gallery with a link to install LastPass. Clicking that link, sends me right back to the previous download page at lastpass.com. At this moment I find it impossible to install LastPass with Safari. Am I missing something?

  • Have you tried installing the extension from LastPass's site? – fsb Oct 2 '16 at 18:23
  • Yes, as described in my question. Clicking their download link takes me to the Safari Extensions Gallery, and clicking the link from there, takes me back to the LastPass download page (the same one I was just on). It's an endless loop. – Jonathan van Clute Oct 2 '16 at 18:28
  • 2
    There are 10 "Download" links on the downloads page at lastpass.com. I'm assuming you're referring to the link across from either Universal Mac Installer or LastPass for Safari. The latter link is lastpass.com/download/cdn/lastpass.safariextz - is that the same URL you're clicking on? When I click on that, it downloads lastpass.safariextz to my Downloads folder as expected. Clicking on the link from the Safari Extensions Gallery installs it directly from the URL safari-extensions.apple.com/extensions/… – tubedogg Oct 3 '16 at 0:44
  • You didn't say which version of macOS and Safari you're using, either. That may affect it. I'm using 10.11.6 and 9.1.2, respectively. – tubedogg Oct 3 '16 at 0:44
  • I'm running Mavericks and Safari 9.1.3. I see only two download links on the page, not sure where these 10 are...? One says Get LastPass Free and one says Download Now. Both take me to the LastPass page on the Safari Extensions Gallery and clicking the link from there, takes me back again. Loopty loopty loop. However the direct link you put in your comment worked so... thanks for that! Still no idea why I can't just click download. – Jonathan van Clute Oct 3 '16 at 1:00

You must log in to answer this question.

Browse other questions tagged .