1

I have recently formatted my hard drive through disk utility and trying to reinstall OS X through the recovery mode but it comes up with the attached picture and the laptop is not going to its Recovery mode. Also i have realised when i press alt Key during the boot process i dont see any hard drive there. enter image description here

  • The image means that your main hard drive where you boot OS X from is missing and that OS X cannot boot. – Edric Oct 1 '16 at 13:23
  • @EdricChan but in disk utility the hard drive is absolutely fine. I have erased it few times no issues. – huseinasj Oct 1 '16 at 13:25
  • Did you try Option+Command+R? This will enter Internet Recovery Mode. – Edric Oct 1 '16 at 13:26
  • @EdricChan i have tried the keys it just comes up with the question mark. – huseinasj Oct 1 '16 at 13:28
1

This occurs when there is no information on any hard drive that the computer can process. This means that at some point you likely accidentally deleted the recovery partition of your hard drive. There is no regular recovery partition so the computer has no idea what to do.

You need to have a bootable USB drive to do anything with that computer besides use it as a very expensive paperweight. Find a USB drive and someone with a Mac and make yourself an OS X (or MacOS) install disk. Then boot from that drive (by holding down Option during boot). Then wipe your internal drive and install the OS (which will automatically install a recovery partition).

| improve this answer | |
  • Thanks for the advice. Thats what i was doing before i created an osx Sierra bootable disk and tried to install it but was getting an message during the installation process but then realise the date and time on my laptop was not correct and had to reset it. Since then it went through fine and i have got the osx installed on my laptop. – huseinasj Oct 3 '16 at 6:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .