9

I'm trying to ssh into a remote server using the format:

user@ip -i ~/.ssh/path/to/key 

and I get the following error:

/etc/ssh/ssh_config: line 55: Bad configuration option: gssapikeyexchange
/etc/ssh/ssh_config: line 56: Bad configuration option: gssapitrustdns
/etc/ssh/ssh_config: terminating, 2 bad configuration options

Connecting to a server without an SSH key doesn't work either.

Thanks.

  • What do the relevant lines look like in your ssh_config? – dr.nixon Oct 1 '16 at 13:01
  • @dr.nixon GSSAPIKeyExchange no GSSAPITrustDNS no – Verpz Oct 1 '16 at 13:12
  • See stackoverflow.com/a/46454141/32453 if you want an option that works with gssapitrustdns still enabled :) – rogerdpack Dec 27 '17 at 17:02
7

Comment out or remove the lines

gssapikeyexchange no
gssapitrustdns no

from your /etc/ssh/ssh_config and you should be good.

  • 1
    What are the consequences? – Max Ried Oct 8 '16 at 7:32
  • Since the new version does not support these options, the only consequence is that it will start to work. Otherwise you will not be able to @MaxRied use kerberos key exchange, which the OP was most probably not using. – Jakuje Oct 8 '16 at 7:58
0

If you need to use Kerberos (and hence the gssapi* options) a viable option is to copy an ssh executable from an older Mac (any version <= OpenSSH_6.7) should work.

cp my-older-ssh /usr/local/bin/ssh

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .