0

I am fairly competent with computers, but I've run into a problem that has me completely stumped. I have an Nvidia Quadro K1200 graphics card in my Mac Pro tower. I have used the Nvidia drivers with no problems, up until a few weeks ago, when Apple released the security update for OS X 10.11. When I tried installing the new driver, it gave me an error. I have now gotten this error in both OS X 10.11 and macOS 10.12, with both driver versions 346.03.15f03 and 367.15.10.05f01. The error appears after running through the whole install dialogue:

Screen Shot 2016-09-30 at 6.02.35 PM.png

Now, I looked at the logs in the Console and it appears to be some kind of SandboxViolation or System Policy error. Here is the list of errors that occurred during the installation:

Screen Shot 2016-09-30 at 6.11.14 PM.png

I can add the full text of the errors if that would be helpful, but I'm wondering if anyone has any ideas of what the problem is and how to fix it.

  • I think it is a problem with SIP, try disabling it apple.stackexchange.com/questions/208478/… (P.S. do that at your own risk, always keep a backup) – Tom Shen Oct 1 '16 at 5:16
  • I thought about that, but it doesn't explain why I was able to install all of the updates until these... Thanks for the comment. I'll try it and see how it goes – NoahL Oct 1 '16 at 5:31
  • It is definitely System Integrity Protection (SIP), but NVIDIA signs their drivers. I would not suggest disabling SIP. Have you tried completely uninstalling the prior drivers and then trying to install the new drivers? I know there were problems with certain versions of the drivers when the security update was released, but NVIDIA's updates since then should have resolved them. – tubedogg Oct 1 '16 at 5:34
  • @tubedogg yes I have tried deleting all drivers and associated files/logs and reinstalling, but to no avail. I'm going to try disabling SIP and then retry the install – NoahL Oct 1 '16 at 6:12
0

I will answer my own question. Thanks to the help of the fabulous commenters, I managed to disable System Integrity Protection (SIP) and install the driver. However, because I couldn't see the screen I had a bit of trouble. I booted the Mac Pro into target disk mode, then took an Apple laptop and used a FireWire -> thunderbolt cable to connect the two. I booted the laptop holding down the alt key. I selected the Mac Pro's recovery partition and booted into that. I disabled SIP in there. However because SIP is hardware specific, I had to change the laptop's startup disk to the one from the Mac Pro. I let it reboot, then installed the driver and shut off both computers. I booted both the laptop and Mac Pro up. The Mac Pro had installed the driver and still had SIP enabled. The laptop rebooted from its internal SSD. I hope this helps someone else!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .