0

I have a British keyboard which I have set in my keyboard preferences, however my mac keeps resetting itself back to U.S.

enter image description here

This annoying feature happens about 5 to 10 times a day. How can I permanently set the language?

2 Answers 2

1

Please check in your keyboard preferences whether you have more than one language setting. If so remove the unwanted language.

Also check In system settings -> Language & Region whether are more than one language is setting. Remove all unless your main language.

Test if works.

2

The default key command to switch Input Sources is Cmd ⌘ space which you may be triggering accidentally.
From comments, I understand the new default since El Capitan is Ctrl ⌃ space , however it also appears it will remain at the old setting if you upgraded from an older OS.

To remove unwanted input sources go to System Preferences > Keyboard > Input Sources & remove all except the one you wish to keep.

enter image description here

Alternatively, if you want to keep the other sources but not trigger them accidentally, then remove the shortcuts in System Prefs > Keyboard > Shortcuts > Input Sources. [This option is only visible if you have more than one source in the previous pref pane.]

enter image description here

With the key command to change sources removed, you can change from the menu bar flag.

If you remove all except one source, the flag icon will disappear.

2
  • Starting with El Capitan the default is actually Control plus Space (as also in iOS 9). But I think some users wind up with Command plus Space via their upgrading process.... Sep 30, 2016 at 15:11
  • Ah, OK. Thanks Tom - mine is probably legacy; long series of in-place upgrades. I'll add it to the answer.
    – Tetsujin
    Sep 30, 2016 at 15:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .