This is driving me crazy and I think I've done all the obvious troubleshooting. Where might OSX be keeping keyboard-specific settings that would do this?

Here's what's happening:

  • When I plug in the keyboard to either USB port on my MBP, it works fine for about 3 seconds
  • Then, the "a" key stops working (no response), and when I press "h" it types an "i" instead
  • It works fine when I boot in Recovery Mode
  • It works fine on other computers
  • Different USB keyboard works fine on this computer

Of note:

  • I am running macOS Sierra 10.12.1 Beta (16B2333a)
  • I recently installed and removed Keyboard Maestro
  • Have you tried going to keyboard settings? Making sure the keys are mapped properly? I think there's a way to check that in System Preferences
    – NoahL
    Sep 29, 2016 at 22:45
  • Yup, definitely nothing weird in there. Set to Canadian English. Tried US English just for fun, no difference. Also, I don't see any keyboard-specific settings in there (the laptop's builtin keyboard works fine, other USB keyboards work fine...). I did go through the "Keyboard Type" wizard there and it successfully sets it up as the ANSI standard US 101/102-key keyboard.
    – maciej
    Sep 30, 2016 at 0:00
  • Entertain me this... if you have a usb hub or usb extension, plug it in through that and tell me the results. Sep 30, 2016 at 0:46
  • Thanks @norcaljohnny I wouldn't have thought of that but it was worth a shot. Unfortunately, same result.
    – maciej
    Sep 30, 2016 at 14:56
  • Same issue. H and I was fixed by Ukelele. But have no idea, how to fix "A", cause it even do not read any keycode. Oct 1, 2016 at 9:53

3 Answers 3


EDIT: I updated my machine to the latest Beta and I also got this issue. I resolved it by going to:

Preferences -> Keyboard -> Modifier Keys...

And then "Restore Defaults".

This is a known issue in latest Beta.

  • Thanks Mateusz, could you link to a source for that? I have seen a few other USB keyboard related reports here and there but with some key differences.
    – maciej
    Sep 30, 2016 at 15:20
  • @maciej I saw some comments here and there that says if you reset the modifier keys preferences it may fix the issue. Worth trying. Sep 30, 2016 at 17:30
  • 1
    Thanks Mateusz, this solved it for me as well. After restoring to defaults, I was able to change them again without issue.
    – maciej
    Oct 3, 2016 at 15:33

As noted by others here, doing a "Restore defaults" on the modifier keys solves the problem (System preferences > Keyboard > Modifier keys...).

I was having the same problem - I restored defaults and the keyboard started working fine :)

Note: Re-configuring your custom modifiers after you restore defaults will not re-introduce the buggy behaviour. i.e., once you've restored defaults, you can go ahead and re-customize your modifiers as they were before.

Happy clacking!


I have met the same issue, you can fix this by install the latest Karabiner-Elements.

  • Welcome to Ask Different! We're trying to find the best answers and those answers will provide info as to why they're the best. Explain why you think the link you provided will answer the question. Links can change and become outdated so we prefer the answers to not just be a link. See How to Answer on how to provide a quality answer. - From Review
    – fsb
    Sep 30, 2016 at 13:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .