3

After I upgraded an MBPr to 10.12 Sierra, the 4k external display connected to it shows significantly less options under Display > Resolution > Scaled (pressing Option to see the resolutions). Before, I always used it at resolutions between 2160p and 1080p, generally 1440p, but those are gone now.Preferences window showing display resolutions, including 2160p and 1080p but nothing in between

What could cause this? How would you troubleshoot it? I'd rather fix it without having to force the resolution in configuration files (like I had to do years ago), but that'd be better than this situation.

Thanks!

  • This is a problem in Sierra, and many people are having this problem. – At0mic Sep 29 '16 at 12:41
1

I purchase a new MacPro (the little black trash can) and shortly after, chose to install the Sierra update. Upon restart, it would not recognize my Apple Cinema's high res settings. After 3 hours with Apple tech support, they filed a report to Apple engineering who solved my problem with this solution:

  • Shut down your machine
  • Unplug all of your monitor's connections (in my case, 2 USB and 1 Thunderbolt) and reconnect using only the ports on the RIGHT side of the Mac.
  • Voila! They said they are aware of the glitch, are attempting to fix it, and until now, this should work.
  • the question refered to a MBP, and this answer is only relevant to a MacPro, but still will be useful for someone. BTW, what a bug... – jesusiniesta Jun 1 '17 at 12:15
0

One possible solution I found in a MacRumors thread is listed below. Note I have not tested this myself as I do not have either Sierra or a monitor that would support such a resolution.

This command in Terminal and a reboot fixed it for me on Sierra.

sudo defaults write /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled -bool true

Also try checking the "Show low resolution modes" option.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .