2

When I try to configure an IKEv2 VPN on macOs Sierra the following errors occur:

nesessionmanager    Failed to find the VPN app for plugin type com.apple.neplugin.IKEv2
neagent Failed to process IKE SA Init packet

From the first line it seems it's not supported at all.

Have you experienced the same issue?

  • Are you polling to find out if other people are having this problem, or are you looking for assistance in resolving it? The former is off-topic. – tubedogg Sep 29 '16 at 20:09
  • 2
    @tubedogg The latter, of course. – Jhack Sep 30 '16 at 7:40
1

In my situation, setting server-side in ipsec.conf:

 leftsendcert=always

solved the problem.

From ipsec.conf documentation:

left|rightsendcert = never | no | ifasked | always | yes

Accepted values are never or no, always or yes, and ifasked, the latter meaning that the peer must send a certificate request (CR) payload in order to get a certificate in return.

Moreover, I had to add to the Keychain the root certificate and trust it in order to validate the certificate sent by the server and I read that if you have intermediate certificates you have to trust them too.

  • For me, manually trusting the root certificate solved the issue. Thanks! – radicand Dec 31 '16 at 2:07
  • Looks like this is not my case :( – Vitaly Zdanevich Feb 28 '18 at 0:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .