2

I just updated from El Capitan to macOS Sierra and I found a problem with preview.

When I open certain PDF with images in it, sometimes the image appears black and sometimes I see it. For example: enter image description here

As you can see, the image is embedded in the PDF because you can see it in the thumbnail. Also, when I use the magnifier, I see the image.

enter image description here

I can reproduce this with other PDF.

I restarted my computer but it's still not working. I was told to repair the permissions under Disk Utility, but still not working. Do you have an idea to fix this?

6
  • The funny thing with that is if I zoom out a lot, I can see the image, but "see" it reallllly small. So it's point less. Using the magnifier, I can see the image but in some cases it makes the image too big not able to see it in a glimpse. It's not the case for all images though. Sep 28 '16 at 17:54
  • PDFs can be generated by hundreds if not thousands of different programs, and while all should theoretically be generating them identically, in practice, nearly none of them actually are. It's likely that there is something in the way images are embedded in the problem PDFs that is tripping Preview up. (Just as there are many PDF generation engines, there are just as many PDF reading engines.) What happens if you try to view the PDFs in Adobe Acrobat Reader?
    – tubedogg
    Sep 28 '16 at 18:05
  • It's working with Acrobat Pro. But it's not only this PDF. So I was guessing a problem for the new version of Preview in macOS Sierra. I was wondering if there was a way to fix this or if anybody else has the same problem. Sep 28 '16 at 18:10
  • 1
    There is no way for a user to fix Preview not correctly rendering PDFs, no. You can file a bug report with Apple to let them know about the problem.
    – tubedogg
    Sep 28 '16 at 18:13
  • 1
    I downloaded the PLoS Genet 2016 Kautt PDF from their website and can somewhat replicate the issue in Preview an also Skim under macOS but it's fine in OS X. No black box but the company logo does disappear/reappear as I use the Zoom feature in macOS while displaying fine in OS X. I'd do as tubedogg suggested and file a bug report. Sep 28 '16 at 18:22
1

I had a similar bit slightly different problem. I had whole pdf pages that were turned black when zoomed in and were correct when zoomed out, but the zoom made them impossible to read. I found this fix https://tidbits.com/2018/01/30/fixing-pdfs-whose-pages-render-as-black-rectangles-in-preview/ basically you have to calibrate your screen. i did it and it worked first time. odd.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .