3

I upgraded to macOS Sierra and my Notes app crashes as soon as its launched.

Has anyone else faced this issue?

Crashed Thread:        13  Dispatch queue: NSManagedObjectContext 0x6080001c41a0

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
*** Terminating app due to uncaught exception 'CKException', reason: 'data can not be nil'
abort() called
terminating with uncaught exception of type CKException

Application Specific Backtrace 1:
0   CoreFoundation                      0x00007fff9adb052b __exceptionPreprocess + 171
1   libobjc.A.dylib                     0x00007fffaf488cad objc_exception_throw + 48
2   CloudKit                            0x00007fff9a6d71d0 -[CKEncryptedData initWithEncryptedData:] + 0
3   CloudKit                            0x00007fff9a6d747b -[CKEncryptedData copyWithZone:] + 92
4   CloudKit                            0x00007fff9a6976cc -[CKRecord copyWithZone:] + 1706
5   NotesShared                         0x00007fffaa6ede18 -[ICCloudSyncingObject newlyCreatedRecord] + 75
6   NotesShared                         0x00007fffaa803ce0 -[ICNote(CloudKit) newlyCreatedRecord] + 65
7   NotesShared                         0x00007fffaa6be0aa +[ICCloudContext deduplicatedRecordsForCloudObjects:] + 703
8   NotesShared                         0x00007fffaa6b8e76 -[ICCloudContext operationsToModifyRecordsForCloudObjectsToSave:delete:deleteShares:saveUserSpecificRecords:addDependencies:] + 1037
9   NotesShared                         0x00007fffaa6c2208 -[ICCloudContext _processCloudObjects:completionHandler:] + 1914
10  NotesShared                         0x00007fffaa6c19fd __53-[ICCloudContext processObjectIDs:completionHandler:]_block_invoke 
  • Most of the problems comes from sierra upgrade over existing system. This is why macOS Sierra has many system changes compared with earlier systems. The best way is, create an USB installer and make a clean install. This will solve most of the current problems. Don't forget to make a backup! – dante12 Sep 27 '16 at 15:13
  • hey man, had similar issues with that. firsthand I had this on iOS, not sure if that was reproduced only after iOS 10 upgrade. then today I discovered this on macOS. I think this is due to some weird symbols or something like that, I've moved my notes to g-docs and notes are no longer crashing. but anyway, having it's so annoying. it's supposed to just work. – sevenfourk Sep 27 '16 at 18:53
  • @dante12, your suggestion is odd. your saying this like macOS is like some windows and had to be re-installed after all major re-leases. macOS is not supposed to work like that. I tend to believe that that crash is linked with the error message it actually shows: Terminating app due to uncaught exception 'CKException', reason: 'data can not be nil' – sevenfourk Sep 27 '16 at 19:01
  • Try disable iCloud Notes in settings. Open Notes, enable iCloud Notes again. – dante12 Sep 27 '16 at 19:45
2

I'm not sure currently, but basically some text/special symbols is to blame.

As stated here: http://forums.macrumors.com/threads/notes-crashing-in-macos-sierra.2000203/

Katalyst2 said: ↑ Me too -- mid-2013 MBA 13. Damn annoying!

EDIT: And as usual, as soon as I post a problem report, I somehow manage to fix it :)

What I just did now was log into iCloud.com and I made a tiny edit to one of my notes (in my case, I deleted one line on a to-do list). Then I waited a few seconds for the data to refresh, and then I tried opening Notes locally again.

Let us know if this works.

0

I faced a similar Notes app crash, few days after upgrading to Sierra. The problem occurred exactly when I tried to disable(remove) an auto-enabled HTTP link from one of my checklist items. The app worked well when I was offline but crashed as soon as I was online.

The solution proposed by 'sevenfourk' above helped me. I changed some text in the iCloud Notes, refreshed and launched the app locally again. Although a bit ad-hoc this solution seems to have worked and the problem clearly seems to be related to iCloud syncing.

0

Turn off notes on your mac (in iCloud preferences) Launch the App (you should find it blank - no notes) Quit the app turn notes back on in preferences then launch notes app

Worked for me..

  • this remove all your local notes - and then need download it again - bad choice – BG Bruno Oct 15 '16 at 19:17
0

Try the below steps. This has worked for me.

  1. Open System Preferences -> iCloud
  2. Provide password and login to the iCloud details to modify
  3. Uncheck the notes option
  4. Launch Notes app and see if it opens fine
  5. Check (select) the notes option in system preference again
  6. Wait till your notes app sync back again into the notes app

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .