2

I can no longer preview text files (e.g. .txt) in Finder.

All I get is a preview pane showing a black square and TEXT.

server1.txt failing to show me the contents in preview

Other files such as .tex files show a normal preview of the contents just fine. I think this changed after I installed Sublime Text, although I could be wrong.

I've tried installing qlstephen but this hasn't helped my problem.

Any suggestions much appreciated!

OS X El Capitan (10.11.6) MacBook Pro Retina.

2

I had the same problem, without Sublime and I used this instead: https://github.com/sindresorhus/quick-look-plugins

| improve this answer | |
  • This still doesn't fix the issue. :-( – Savara Sep 27 '16 at 16:11
0

In my case the same issue (SublimeText plain texts not showing in Quicklook) was solved by adding .txt to the file name.

| improve this answer | |
0

In my case it was the plugin qlcolorcode that was failing, thus prevent the preview to work. You can if you have the same problem with the following command: qlmanage -d4 -p '/path/of/your/file.txt'

You may see the culprit:

...
[DEBUG] Thumbnailing file:///path/of/your/.txt - type: public.plain-text - generator: <QLGenerator /Users/gomino/Library/QuickLook/QLColorCode.qlgenerator> (try #1)
dyld: Library not loaded: /usr/local/opt/lua/lib/liblua.5.2.dylib
  Referenced from: /usr/local/bin/highlight
  Reason: image not found

Upgrading highlight to the latest version (3.53) fixed the problem. brew upgrade highlight

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .