0

I can't download / get calendar app from the iOS app store. I just updated to iOS10 and when I finished I noticed that something was missing in my home screen. I took me a while to realize that I lost my calendar app.

When I tried to get it from the app store I just couldn't. I can push the "get" button that transform into a install button. When I tried to push install I just can't. I can get any other apps from the app store. Buy or just get it.

Is this a normal behavior?

Thanks!

app store screenshot

1

Try to restart your device whit:

  • On an iPhone 7 or iPhone 7 Plus: Press and hold both the Sleep/Wake and Volume Down buttons for at least ten seconds, until you see the Apple logo.
  • On an iPhone 6s and earlier, iPad, or iPod touch: Press and hold both the Sleep/Wake and Home buttons for at least ten seconds, until you see the Apple logo.

If the problem persists, make sure you make all system updates.

Try an alternative to load a Backup of your device from iTunes to restore the calendar App.

  • I've already restarted several times. I've noticed that the data for calendar and reminders are still in the phone. Perhaps I'll try restore the iPhone from backup – lpuerto Sep 27 '16 at 12:57
  • @Ipuerto - ok let me know if it works. – momomorez Sep 27 '16 at 13:06
  • returned after I restore the iPhone.... it was a bad installation. Walled was also missing. – lpuerto Sep 27 '16 at 15:15
0

I had similar issue on iOS 12. What helped me is reinstalling OS from scratch with the help of iTunes.

  1. Switch to the DFU mode (see link)
  2. Dialog window will appear in iTunes with message, that iPhone is broken and you can either Update or Recover. Press Recover (Update may work. I did not test this.)
  3. After that iTunes will start iOS download
  4. iPhone waits max 15 minutes. If download takes more than 15 minutes, iPhone does not wait longer and reboots (do not panic, ignore that for a while)
  5. After Download is completed, go to DFU mode again (if Phone has rebooted)
  6. After iTunes has finished Recovery process, phone will reboot
  7. Then pass standard procedure of the phone activation and configuration

At the end, I've got recovered device with all standard applications. What was weird is that I wasn't able to restore backup. I do not know why.

Also after I've executed "Erase All Content and Settings", I've lost my apps again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .