I have a MacBook Pro with El Capitan 10.11.6 signed in to iCloud. I also have an iPhone 6s Plus which is also signed in to iCloud. After upgrading my iPhone to iOS 10 I have follow-ups showing notifications and also frequently appearing push notifications about "approve your device".

I push it, then enter my passcode to iPhone and see this:

Approve This iPhone Go to one of your devices signed in to iCloud to approve this iPhone.

Waiting for approval (spinning wheel)

Sooo... I do not have any popup or window or anything else on my MacBook to approve iPhone. How can I do this?

  • Unfortunately I can't answer [not enough reputation] but take a look in the comments of Jean-Francois Beauchamp below the only answer for this question. – Fawkes Apr 6 '17 at 8:42

This is almost certainly a keychain issue. Try these steps:

  1. Turn off iCloud Keychain on both the MacBook and iPhone.
  2. From your iPhone, go to Keychain and tap Approve with Security Code.
  3. When prompted for the 4-digit iCloud Security code tap Forgot Code.
  4. Follow the prompts to reset the code.
  5. Now this device should have iCloud Keychain enabled and working.
  6. Now from your MacBook, enable iCloud Keychain.
  7. You should get a notification on the iPhone about this. Enter your iCloud password in the prompt.
  8. iCloud Keychain should now be enabled.

Hopefully this gets rid of the Approve your device notifications! Let me know how you go.

[EDIT] ***Make sure you have a passcode setup on your iCloud Keychain on your computer. If you don't set one up and then try approving your phone again. That is what made mine work. Hope this helps!

  • This is a good thing to try. You can also contact support if your iCloud setup is stuck for more than an hour. If there are issues server side generally, with capacity or with your account in specific - doing the right steps might not even work. – bmike Oct 9 '16 at 16:26
  • 6
    I am also stuck at the same place, and the above instructions are not working for me. I don't have an Approve with Security Code option. Or maybe I am not at the right place. I have iOS 10.1.1, and I am in Settings->iCloud->Keychain. In there, there is an an option to activate iCloud Keychain. If I activate this, I am being asked for my Apple ID password. Once I enter this, it simply says Enter your code. If I enter my iCloud password here, it is being accepted. Then I get the message "Go to one of your devices signed in to iCloud to approve this iPhone". – Jean-François Beauchamp Nov 4 '16 at 2:05
  • 1
    I'm also stuck with this f*cking issue for months, all I could say is "f^cking Apple", its hardware is excellent but software is really a crap :( – Tien Do Sep 17 '18 at 11:13
  • It is worth noting that I dismissed this answer as I do not have iCloud keychain enabled on any of my devices. However. I enabled iCloud keychain, it asked for my iCloud password and device password. Then the warning disappeared. I then disabled keychain again. – danielson317 Jun 1 '19 at 3:56
  • What if you don't have an iPhone? Are they forcing me to get an iPhone just to use a desktop Mac??? – pete Aug 10 '19 at 19:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .