26

I've had this problem for a while, but I hate not knowing or getting to the bottom of things, so here I am! :)

On an iMac I am running El Capitan 10.11.6 and in the Mail app I successfully send and receive emails from five separate accounts. So all seems good.

However, if I go to System Preferences > Internet Accounts and manually select each of these five accounts, for two of them I get the following Can't connect to the account error message:

enter image description here

Now, when I enter my password, I get the Unable to verify account name or password prompt in red text:

enter image description here

I manage my own domain and email accounts, so know for a fact I have the correct passwords. And, as I said, I am using these accounts fine within Mail. I also use them fine on various iPhones and iPads and other Macs.

Any suggestions as to what's going on?

11
  • Try prefs>Accounts>Advanced & see if 'Automatically detect & maintain...' is enabled. I've known that to change the port & SSL settings below.
    – Tetsujin
    Commented Sep 27, 2016 at 7:12
  • @Tetsujin Thanks for the suggestion. Did you mean System Preferences > Internet Accounts > Advanced ? If so, I don't get the Automatically detect & maintain... option.
    – Monomeeth
    Commented Sep 27, 2016 at 8:00
  • Mail prefs, sorry - it's set individually for each account
    – Tetsujin
    Commented Sep 27, 2016 at 8:12
  • There are actually 2 places, one for incoming, one for outgoing [sorry, I'd forgotten, been a while since I did it] The other is in Outgoing SMTP > edit > advanced.
    – Tetsujin
    Commented Sep 27, 2016 at 8:15
  • Ah, found it. The Automatically detect & maintain... option is enabled. So are you suggesting I should I uncheck the box?
    – Monomeeth
    Commented Sep 27, 2016 at 8:21

6 Answers 6

12

I was having this issue also, tried restarting the computer, editing the SMTP, nothing worked. I went into internet accounts and clicked the remove button (-) in the bottom left. After removing and re-adding the account everything seems to be working fine!

2
  • 3
    Since I don't have enough reputation, I put it here in the comments. This happened to me after I changed my password. I solved this by going to: Mail -> Preferences -> Accounts -> Server Settings and then in the Password field changing it to the new password. Mails finally started coming in again ;) Commented Jun 26, 2017 at 11:54
  • If you're having this issue for Calendar (as I was), then following @SandervandenOord's instructions will solve the same problem. Commented Jan 8, 2019 at 20:29
6

This is a frustrating bug! Here's what worked for me, though I don't know which of these things ended up doing the trick (Mac OS 10.12.6, Mail 10.3):

  1. Open Mail preferences and on the accounts tab paste the new password into the Server Settings tab.
  2. Disable the account on the Account Information tab.
  3. Restart the whole computer. (probably not necessary)
  4. Launch mail, open up preferences again to the accounts tab (this time it showed a green "Online" status).
  5. Re-enable the account on the account information tab.
  6. At this point, for some reason Mail thinks the account is offline, though I never set it to offline. Click the get mail button and it will ask if you want to bring the account online, click bring all accounts online.

And finally after all that it started working again. This is so ridiculous. Whoever thought you would have to reboot your entire Mac just to update your email password.

3
  • Yes, since macOS 10.12.6. I am experiencing the exact same bug. It happened to me twice. I don’t recommend pasting the password to the System Preferences > Internet Accounts settings.
    – user136834
    Commented Nov 19, 2017 at 0:01
  • 1
    This worked for me, although it was enough to disable the account, change the password, then re-enable it without also restarting.
    – Defragged
    Commented Mar 13, 2020 at 9:59
  • @Defragged Thanks, I made a note in the answer.
    – devios1
    Commented Mar 13, 2020 at 13:11
2

I had the same problem, The solution is to delete the entry for the account password in Keychain Access.

the name for the account is:

com.apple.account.Exchange.password

there seems to be a bug as this account doesn't show till you search for a string that matches in this account, like "Exchange"

I got the hint for this solution from this answer

enter image description here

0

Solved, for me at least.

Stop everything, entirely remove ~/Library/Keychains/U-U-I-D/, and reboot.

More details:

https://apple.stackexchange.com/a/325124/185723

0

I had the same problem and also solved it by changing the app password in Keychain Access! Keychain Access had an old password stored there.

0

what you need to do, is in the Settings -> Internet Accounts window. Fill in the password in the empty password field.

Now, hit "tab". And then enter.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .