6

I have recently updated to macos Sierra and have a very strange thing happening with my Fn key. I have looked everywhere but cannot find anyone with the same issue.

Whenever I press the Fn key, it looks like the first key I press immediately after holding it is not recorded, instead, it acts like a long press of that key, and only the second press acts as normal.

For example: I do Fn+Delete to forward-delete, then it deletes as normal delete, and then starts deleting everything after a second, exactly like if I was just long pressing the delete key. If I press the delete key a second time (while holding the Fn), then it does act as expected. The funny thing is that once I release the Fn key, whatever I press after having released it still acts like if I was still pressing Fn, and then the rest of the key presses are normal again.

I first saw this issue with Fn+Delete but it happens with all keys, Fn+RightArrow will make my cursor go through all the text, etc. I have tried a SMC reset and a PRAM reset, I logged out and logged in to a newly created account to see if it was some issue in my user account, but nothing seems to solve it. I also tried turning sticky keys on and off.

Please help, I can't think of anything else.

5

Are you using USB Overdrive? I went into the USB Overdrive settings, selected "Any keyboard, any application" and deselected the Enabled checkbox, and the problem seems to have disappeared

  • I do use USB Overdrive. I tried disabling all the options in USB Overdrive, that did not work but I checked online and saw there is an update for Sierra compatibility and that sorted it all. Many many thanks!! – user1579874 Sep 29 '16 at 20:09
  • Whew.. This fixed the problem for me too! I was almost ready to reinstall macOS from scratch, as multiple reboots nor SMC reset seemed to help at all. Thank you so much! – thykka Nov 5 '16 at 13:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .