3

After doing a clean install of macOS Sierra I occasionally get the 'missing app icon' (the original app icon with a question mark superimposed). When this happens clicking the app icon doesn't launch the app (and I need to go to /Applications and re-drag the icon to the dock). Anyone else experiencing this issue?

I also get the following warning for the apps this is happening with when trying to do an update:

Sketch can't be updated when it is running from a read-only volume like disk image or an optical drive. Move Sketch to your Applications folder, relaunch it from there, and try again.

I've tried opening from the command line to verify I am indeed opening from the Applications folder with:

open /Applications/Sketch.app

Any thoughts?

5

Specifically regarding the warning you are seeing, from Rogue Amoeba:

Gatekeeper Path Randomization ... works by mounting a read-only disk image in a temporary path in the file system, copying the app onto that disk image, then launching the app from there.

GPR is a new security feature in Sierra intended to close a loophole where malicious programs could be packaged with Developed ID-signed legitimate programs, and thereby bypass Gatekeeper security intended to prevent unsigned applications from running.

GPR is disabled after an application is moved to the /Applications folder, however software update systems will fail, because when the new version of the app is downloaded, it has to be moved by the user before it will execute outside of the read-only disk image imposed by GPR. Therefore the best way to update is to download an updated copy of the app from the developer's website and manually move it to the /Applications folder.

  • You're welcome. I wouldn't be surprised to find out GPR is responsible for the other weirdness you're seeing, if the app tries to change or overlay its icon somehow. – tubedogg Sep 26 '16 at 21:44
  • I had this problem with the Textmate beta updating itself. Another method that seems to work (though no less annoying I'm afraid) is to move updated apps out of /Applications (I dragged it to ~/Downloads while holding command) and then move it back to /Applications. No more broken aliases… until the next update anyway. – Nilloc Dec 13 '16 at 17:34
  • My app is Developer ID signed, it's distributed in a zip file and nevertheless Sparkle update keeps working from /Applications without any changes. What am I doing wrong? Or is GPR triggered in some particular, not all cases? How do you reproduce the OP's problem? – swa16 Feb 14 '17 at 11:50
6

Cause: Gatekeeper Path Randomization introduced by macOS Sierra.

Steps to Fix:

  1. Run command: xattr -dr com.apple.quarantine /Applications/Your.app
  2. Drag app back to Dock;
  3. Restart Mac.

Consequence:

  • App icon stays at Dock after restart
  • Check for updates works
  • The app icon and check for updates are OK even after application update. – Jing Li May 13 '17 at 9:35
  • 1
    This command fixed the issue of not being able to update apps that I've been having (they would display "Can’t be updated when it’s running from a read-only volume like a disk image or an optical drive"). All I needed to do was quit the app and run the command, running the app worked fine then. – BarrettJ Jun 14 '17 at 13:59
0

Close the app. Move the app from /Applications to another path and then move it back to /Applications.

It worked for me (the app was just Sketch.app)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .