• iMac (21.5-inch, Late 2009)
  • El Capitan 10.11.6
  • Non-Apple modem/router

Wake on LAN isn’t working. I have tried a variety of methods: iOS apps (Fing, iNet, Mocha); Mac applications and scripting on another Mac (WakeOnMac, wakeonlan perl script).

Yes, I’m on a local network, and yes I’ve ticked the ‘Wake for network access’ in System Preferences. Also checked with pmset -g that womp = 1. I have also tried overriding networkoversleep (1).

I initially believed the Ethernet (which directly connects the iMac to the router and should make this process more reliable) disconnected during sleep. I tested this by opening System Preferences > Network and leaving that open while I sleep it. When I woke it from sleep, the Network Preferences panel was still open (obviously) and Ethernet (at the top) showed as Disconnected and features a red dot beside it. It reconnects very quickly, but that’s no good for WOL.

I have now tested installs of Mavericks, Yosemite and macOS Sierra on a separate partition. Mavericks and Yosemite both allowed WOL (despite the Ethernet 'disconnecting' issue still being there, suggesting it doesn't actually disconnect). macOS Sierra, as El Capitan, does not allow WOL. The pmset settings and 'Wake for network access' etc. are all the same.

Does anybody know of an obscure network setting somewhere that disables WOL despite it being enabled in pmset?

  • I'm having the same problem on an early '09 Mac mini that I just upgraded from Mavericks to El Capitan. WOL over ethernet worked fine on 10.9, but nothing I've tried has worked on 10.11. For what it's worth, I see in Wireshark that the magic packets are still reaching my mini when it is awake. Commented Sep 28, 2016 at 6:28
  • Incidentally, I was never able to get WOL working over wifi on the mini but ethernet worked reliably. Also, I don't even have a router between my mini and the computer that's trying to do the waking. Commented Sep 28, 2016 at 6:30
  • I found this link: ptarmiganlabs.com/blog/2015/07/13/… which suggested using a USB ethernet adaptor. I have an adaptor lying around, and it indeed seems to work on El Capitan! Seems crazy that a cheap 3rd party adaptor works but the built-in interface won't. Hopefully someone else can find a solution not requiring an adaptor. Commented Sep 28, 2016 at 7:00
  • FYI, the generic adaptor I'm using is: amazon.com/Gigabit-Ethernet-Network-Adapter-1000Mbps/dp/… which works fine on OS X after installing a driver. Commented Sep 28, 2016 at 7:05
  • @JulianPanetta: Interesting about the dongle, suggesting the network card itself (or OS X's management of it?) is toasted. I notice the USB 2 version is 10/100 whereas the USB 3 is 10/100/1000. Is yours USB 3, do you have a USB 2 or 3 port on the Mini, and (if USB 2) does it limit speeds back down to 10/100?
    – Pwdr
    Commented Sep 28, 2016 at 7:31

1 Answer 1


Wake on Lan only works if the Mac is sleeping. You cannot wake up a Mac that has been shutdown no matter what third party apps you have. Mac's are not designed to Wake-up from LAN when shutdown for security reasons.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .