2

I am not a Unix, Linux, or OS X guru, far from it. I have a Macbook Pro that is almost 4 years old and I am running Yosemite: 10.10.5. I am up-to-date with the software updates.

I have been having problems with my Time Machine. I expect to see anywhere from 5 MB/s to 30 MB/s when backing up in optimal conditions (Time Capsule in the same room for the lower bandwidth, ethernet connection to server for the higher bandwitdh). Instead, I am getting a trickle. Today after what I did as described in the first edit I got 26 MB of data backed up in one hour. I am familiar with the fact that sometimes TM needs many hours to sort itself out, and then eventually it kicks off. So that's why I did not worry at first. I have been trying to do a backup since the 5th of September, first at home (over wifi) and now in the office (over ethernet). I have had Time Machine and Time Capsule for about 10 years now over 3 different laptops and I have never had this kind of problem. It makes no sense. I am either missing something glaringly obvious or something is broken in my laptop.

Here are some facts and some hacks I have already tried:

  1. my wife also has a mac. On our home Time Capsule, her backup (80GB) took a couple of days, without problems. Mine was stuck at very low bitrates, a few MB/day.

  2. I erased both sparsebundles from our Time Capsule and started over. Again, my wife’s worked very well. Mine (180 GB) didn’t.

  3. I saw on various forums some possible solutions:

    • Exclude the backup disk from the antivirus software: I did, and it did not make any difference

    • Unthrottle low-priority processes:

      sudo sysctl debug.lowpri_throttle_enabled=0
      

      I did, and it did not make any difference.

    • After checking the priority of all processes:

      ps -eo user,pid,nice,pri,command
      

      I increased the priority of the backup process:

      sudo renice -n 5 -p 1523
      

      no difference, meaning that Time Machine is stuck on: "234 bytes of 280.09 GB, calculating time remanining…"

    • I tried restarting in safe mode and then restarting again. No difference.

Now the plot thickens. I am currently in a company with some real network admins who however use Linux and are unfamiliar with Macs. So they are puzzled.

They set up a NAS volume with plenty of space for me. I accessed it using

  sudo tmutil setdestination afp://TimeMachine:<password>@192.168.1.220/TMBackup

and after that Time Machine could indeed find it.

Furthermore, they are monitoring the volume and the size of the sparsebundle file is increasing, currently at 1.05 TB in approximately 1 hour, which sounds about right. However, during this time Activity Monitor did not show ANY outgoing data flow, and my TM status is still at 234 bytes of 280.09 GB.

It looks to me like there is a bug in Time Machine and in Activity Monitor. However, this sounds strange and unlikely. Perhaps a virus? Sophos tells me I am clean.

How can I analyze and resolve this?


PS: A small twist. Rather than

  sudo tmutil setdestination afp://TimeMachine:<password>@192.168.1.220/TMBackup

I tried using the Go/connect to server command

afp://192.168.1.220/

Here I gave my personal credentials for the NAS volume, which then appeared in the Finder under Network. From the Time Machine control panel I then selected my own disk "paolo" rather than the generic service name TMBackup. This seems to work better. Afer 20 minutes we are at a whopping 16 MB and Activity Monitor shows a trickling of data being sent over every few seconds. In about 3-4 months my backup will be all done!

  • Do you see bad throughput only when using TM or also when copying data directly to the TC or the network destination? In case you have a spare USB drive, what happens if you configure this as a TM target and run a backup on that one? – nohillside Sep 27 '16 at 9:26
  • Hi @patrix good points. I copied a large file (8GB) to the remote volume using wifi and got about 2-5 MB/s. With an ethernet cable I got between 15 and 30 MB/s. So I think it is safe to say that the network and copying functions ARE working well. Then I connected an external USB drive and made it the target disk of my TM, as you suggested. It's been running almost 3 hours and it has so far done 60 MB out of a total of 280 GB. So I think it is safe to say that it is NOT working well. I would conclude that there is something wrong with my TM. Can I delete it and reinstall it from AppStore? Thx – pdini Oct 4 '16 at 12:54
  • Initial TM backup is always kind of slow, but 60 MB after three hours seems to be very slow. TM is part of OSX, so you can't install it. You could reinstall the whole OS, but I doubt that this will fix any TM config things. – nohillside Oct 4 '16 at 12:59
  • Indeed, as I feared there is something wrong with my TM. I'll keep tinkering and will post any solution I might stumble across. Thanks for your help. – pdini Oct 6 '16 at 8:50

You must log in to answer this question.

Browse other questions tagged .