0

There are about a dozen questions similar, but all of them get further along in the startup than I do. Purchased a used MacBook Pro 2012 (December 2011). Seller (whom I trust) said that it wouldn't start and she was told a procedure that included removing the battery. She was scared of that and took it to a genius bar, where it was "fixed" for free. Must have been something simple if they did it out front while she waited.

It worked fine for her and she installed El Cap but stopped before the "assign admin password." I did that so that I could log in and verify WiFi worked and no obvious issues. Bought it and it worked for me for a few days.

But now, press power, screen lights up but goes dark within a half-second. Sleep light on but not pulsing. Keyboard not lit. Hold power down and can hear the turn off click (and see the sleep light go out). Resetting SMC did not help. Battery is fully charged according to the LEDs.

I'm guessing that it's the same problem she had, but maybe not.

  • 2
    Besides resetting the SMC, what else have you tried? Just wondering what happens if you try to start up in Safe Mode? Have you tried using Apple Hardware Test? Also, do you know if the MacBook will startup in Target Disk Mode? – Monomeeth Sep 25 '16 at 23:20
  • Also tried the PRAM reset, but since it sleeps before the chime, not sure it did anything. I might open the back and look for the internal reset button. Probably whoever told her to remove the battery was thinking of some model that hides that button under the battery. Or they actually meant unplug the battery (which can be done on any model). Considering that it becomes non-responsive less than a half-second after power on, obviously cannot do TDM, Safe, nor any other mode. Why did someone delete clarifying comments I made? – WGroleau Sep 25 '16 at 23:26
  • Do you have the power adapter plugged in when you attempt to power it up? – Allan Sep 26 '16 at 1:29
  • @Allan: same thing either way. – WGroleau Sep 26 '16 at 2:20
  • If possible, can you unplug the Mac, remove the battery, wait about a minute, and then try booting without the battery (ie plugged back into a power socket)? – Monomeeth Sep 26 '16 at 2:33

You must log in to answer this question.

Browse other questions tagged .