0

I was trying to remove extended attributes (quarantine) in order to install Fusion. This is what I ran in terminal:

sudo xattr -rc /Volumes/VMware\ Fusion/VMware\ Fusion.app

Apparently, the instruction was applied to /Volumes instead of just the app. In consequence, lots of troubles appeared after a restart:

  • characters are not being displayed (only question marks inside a box)
  • permissions or ownership of lots of folders and files were messed up
  • chaos

I would like to know why this happened and if there's any way to revert it back to default. I tried to run RepairHomePermissions from recovery mode as describe here: macOS Sierra Recovery HD Changes but it didn't help. With a different system user everything works fine so I don't know if only the home folder was affected.

  • To remove the quarantine attribute, it's better to use xattr -d com.apple.quarantine and leave other extended attributes in place. – nohillside Sep 25 '16 at 14:10
1

If you really entered the command as shown, the change should be local to VMware Fusion.app. But anyway, if you want to restore things back to sanity, you can

  • redownload and reinstall macOS Sierra from the Store
  • boot into the Recovery Partition and reinstall from there
  • That's what I will do but I was mainly looking for an explanation. Is xattr capable of that kind of destruction? It changed the ownership of home folders from user:staff to root:wheel – Pablo Fernández Sep 25 '16 at 14:14
  • No, it isn't. If you are looking at permission issues, xattr isn't the culprit. – nohillside Sep 25 '16 at 14:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .