0

I have a MacBook Pro (15-inch, Mid 2010, MacBookPro6,2) which does not switch to battery power when the power adaptor is removed. It simply goes off. However the battery is reported as 100% charged. I can only use the MacBook with the power adaptor plugged in.

When plugging in, the LED shows orange for a few seconds, then switches to green. When I remove the power adaptor for more than a few seconds, the clock resets to Jan, 1 on the next reboot.

The battery is two or three years old but it is not the original one. It is possible that it has degraded over time but even then I would expect it to deliver power for at least a few minutes, so I think the problem is something different. Also the battery worked as usual a few days before.

I tried a SMC reset (shift-ctrl-option-power) which did not fix the problem. Is there a way to find out whether the SMC reset was in fact executed?

Anything else I can do?

Here is the battery info:

Battery Information:

Model Information:
  Serial Number:    W01107AW7D3BA
  Manufacturer:     LMP
  Device Name:      A1321
  Pack Lot Code:    3230
  PCB Lot Code:     30db
  Firmware Version: ddae
  Hardware Version: dac2
  Cell Revision:    2b39
Charge Information:
  Charge Remaining (mAh):     6996
  Fully Charged:              Yes
  Charging:                   No
  Full Charge Capacity (mAh): 7033
Health Information:
  Cycle Count: 163
  Condition:   Normal
Battery Installed: Yes
Amperage (mA):     0
Voltage (mV):      12508
1

Okay, the steps for resetting the SMC on a MacBook Pro with a built-in battery are as follows:

  1. Shut down your computer
  2. Keep the MagSafe adapter (power cable) plugged in.
  3. Press at the same time shiftoptioncontrol (on the left side of the keyboard) and the power button
  4. Let go
  5. Turn your computer back on with the power button.

Is that what you did?

Resetting your PRAM/NVRAM

Older Macs had what's called Parameter RAM (PRAM), newer Macs use Non-Volatile Random-Access Memory (NVRAM). It may be worth you resetting your PRAM/NVRAM, using these steps:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again and you here the startup chime.
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. mouse speed, time and date/timezone, etc).

Let us know how you go.

  • I tried both resetting the SMC and the PRAM, but it did not help. – nn4l Sep 25 '16 at 15:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .