4

I don't want every link I send through iMessage to be accessed and embedded inline. I can't find a preference setting or defaults key to turn this off.

In this example image, I would want the YouTube link to be sent as a bare link, not a movie + screenshot: Example

2
  • Paste without style.
    – At0mic
    Sep 25, 2016 at 5:10
  • @Iron I think you're confusing iOS/macOS and rich links in Messages with rich text?
    – grg
    Sep 25, 2016 at 10:52

2 Answers 2

1

That can't be disabled, it's part of iMessages.

https://support.apple.com/en-us/HT206894

3
  • Everything on that page is also annoying, but I'm specifically targeting rich link expansion, which isn't mentioned.
    – finna
    Sep 25, 2016 at 12:27
  • It isn't mentioned specifically, true. Also not mentioned on the Apple sites I visited was how to disable it (apart from turning off iMessages and just using SMS). I suggest letting Apple know you want this feature: apple.com/feedback/iphone.html
    – fsb
    Sep 25, 2016 at 13:41
  • I guess that's the best I'll get.
    – finna
    Sep 25, 2016 at 17:16
1

You can add a dot (.) in front of the http before sending it. That should send the link as a link instead of a "rich link" .http://bla.com

2
  • It doesn't.
    – finna
    Oct 7, 2016 at 19:31
  • 1
    It works if you add text (or a dot) both before and after ( . bla.com . )
    – cwd
    Feb 27, 2017 at 14:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .