0

I updated my iPhone 5c to iOS10. I have three apps that have been stuck in the dimmed 'waiting' state for almost 24 hours now, and they don't delete when I hold down and click the x to delete them.

They appear in the App Store as the loading circle with the square in it.

My iTunes library on my computer has no 'app' section to delete apps from, and when I go to my iPhone itself through iTunes, it doesn't show the apps i'm trying to load as options on my phone, it just shows the icons.

from my itunes

WhatsApp and Pokemon GO are two of the apps stuck in the waiting state. Does anyone have a solution that isn't a factory reset, or is that my only hope of fixing this?

1

I had a discussion with Apple about that exact same issue. I have an iPad 4th gen and when I updated to iOS 10, apps just wouldn't update or delete. They told me to

  • Try restarting my iPad
  • Signing out of my Apple ID and signing back in

But since you already tried that, and it didn't work. You will have to do a factory reset. I recently did a factory reset, and I am very impressed with how much data was still saved from my device even when I didn't back it up. I'm sorry, but that seems to be the only hope.

0

I would try doing a full reboot of your iPhone by holding down the power button and home key simultaneously for about 10 seconds until you see the Apple Logo appear on a black screen.

If that doesn't resolve the issue, I would also:

  1. Go into your App Store app
  2. Scroll to the very bottom of the screen
  3. Tap on your Apple ID
  4. Tap on Sign Out

Once you've signed out, sign back in and see if that makes a difference.

  • @ monomeeth thank you for the reply, but sadly neither of those worked :( i'm trying to do an icloud backup now. – sage Sep 24 '16 at 22:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .