3

I have it enabled on my 2013 Retina MacBook Pro, my Apple Watch is on the same wifi network, and bluetooth is enabled as well. When I wake up my Mac, it says “Unlocking with Apple Watch” for several seconds, then it times out and prompts me to enter my password. I don't receive any notification on my watch either. I tried disabling and re-enabling the feature, but that doesn’t have any effect. Any ideas?

  • 2
    I was having this same problem. Uncheck the "Unlock with Watch" box. Then hold down both buttons on the watch until it resets (hold until the Apple logo appears, then release). Then re-check the box on your Mac. Worked for me. – TMHahn Sep 24 '16 at 21:15
  • I posted it as an answer, just to make it official. – TMHahn Sep 24 '16 at 21:54
4

Uncheck "Unlock with Watch" box in System Preferences.

Then hold down both buttons on your watch until the Apple logo shows, then release. This will reset your device (no data or app loss).

Let your watch re-start.

Unlock the watch.

Then, back on your Mac, re-check "Unlock with Watch."

1

In case the accepted answer doesn’t work for anyone, my problem was due to Wi-Fi and/or Bluetooth taking too long to wake up on my Late-2013 iMac. I don't want it to sleep anyway, but Sierra toggled that back on.

In System PreferencesEnergy Saver, I enabled Prevent this computer from sleeping automatically when the display is off.

I'm not sure if there is a problem causing this delay on my iMac specifically, but it now unlocks instantly upon wake.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.