After upgrading to macOS Monterey, I tried to run git from Terminal but it kept giving me the following error:

xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun.

How do I fix it?

  • 7
    I was really confused that the question is 5 years old but says "after upgrading to macOS Monterey," which was released less than a month ago. Then I checked the edit history and it looks like you're updating it with each new release. Good on you, sir.
    – Travesty3
    Nov 8 at 17:03
  • 2
    You sir are a real gentlemen! Doing this for 5 years, and updating your question, amazing!
    – Tancho
    Nov 8 at 18:06
  • 1
    @Tancho Thank you sir :)
    – The Onin
    Nov 9 at 0:55
  • 1
    @Travesty3 haha me the same. I just joined appleExchange only to upvote.
    – jabujavi
    Nov 9 at 10:51


Open Terminal, and run the following:

xcode-select --install

This will download and install the Command Line Tools package and fix the problem.

You do not need Xcode, you can install only the Command Line Tools here, it is about 130Mb.

If the above alone doesn't do it, then also run:

xcode-select --reset

Further reading

The problem is that one needs to explicitly agree to the license agreement. As a follow on step, you may need to reset the path to Xcode if you have several versions or want the command line tools to run without Xcode.

xcode-select --switch /Applications/Xcode.app
xcode-select --switch /Library/Developer/CommandLineTools

I found the solution in this question, Command Line Tools not working.

You may get an error message: "Can't install the software because it is not currently available from the Software Update server". In this case xcode-select --reset works as pointed by akozin.

  • 3
    I also had to run sudo xcodebuild -license accept
    – a113nw
    Dec 29 '20 at 19:07
  • solved my "Can't install the software" issue that occured with sudo xcode-select --install.
    – jerik
    Feb 11 at 23:51
  • xcode-select --install solved my issues with Git command. Issues was after update from macOs 11 to 12. Nov 3 at 4:58
  • It happens after updating macOS from Bigsur to Monterey.
    – anaszaman
    Nov 3 at 12:00
  • "218 hours remaining" wtf... :O :D :D
    – OZZIE
    Nov 25 at 18:51

If you don't want to install nor use Xcode (I don't) you can install only command tools for Xcode (please see Edit)


  • you have AppleID


Go to https://developer.apple.com/download/more/ and find Command line tools OS X 10.11) for Xcode 7.1. Then install downloaded .dmg package.

Newer versions

It should work with newer versions of Command line tools OS X however I tested it Command line tools OS X 10.11) for Xcode 7.1 particular version.

Update to macOS 10.13

After updating do macOS 10.13, I had to install Command Line Tools (macOS 10.13) for Xcode 9 - also works great.


As @setholopolus mentioned in comment,

xcode-select --install

Also installs only command line tools for Xcode.

You can also verify this at: http://osxdaily.com/2014/02/12/install-command-line-tools-mac-os-x/

I am leaving my answer in case you'd have problems with installation via cli.

PS credits to this SO answer: https://stackoverflow.com/a/33593066/2029818


For macOS High Sierra, just run the same command:

xcode-select --install

and everything will get back to work.

2019 UPDATE: This is needed for every new macOS version, so it'll work for Catalina as well.


Here are the steps I needed to go through for Mojave:

First xcode-select --reset.

Next I needed to upgrade xcode tools to the latest version: sudo softwareupdate -ia --verbose (NB: this runs all available updates from the app store, there is a way to specify that you only want to update one app/program, but I don't know it off the top of my head).

You can try this command another time if it shows some inconsistent behaviour during the first try.

Finally verify that it worked by using a git command of your choosing, e.g. git status.


I tried the xcode-select --install but I was forced to install it from the App Store.

Then all git stuff ran smoothly.


xcode-select --install and xcode-select --reset didn't work for me.

I had to download it manually from Apple Developers website: https://developer.apple.com/download/

Choose the Command line of your current OS.

Screenshot for link


The accepted answer is correct, but also note that git does not make it obvious if the error is coming from remote or from local. If you are running OS X on your remote, your install problem may be on the remote side and you'll see the same error on git clone and git pull but NOT on git status.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .