8

One thing I've noticed while using Siri on macOS Sierra is that Siri's voice is not natural (not even close to natural, it sounds like the default system voice of my Mac). How can I get Siri on macOS to sound as high-quality and natural as Siri on iOS?

I have downloaded Samantha voice for Mac before. I even tried deleting Samantha's voice and redownloading it, but Siri's voice is still like a robot!

When I change Siri's voice to Male (or any other accent or language) and then revert it back to Female, the voice gets better (still not the Siri I have on my iPhone), but then again after a few moments, it's back to default system voice.

What is going wrong here?

  • Welcome to Ask Different. This site works best if you ask a clear, concise question which can be answered directly. As written, your question is very unclear; it's actually more of a statement rather than a question. Also, be sure to have a look at our Help Center specifically on how to Ask good questions. – Allan Sep 24 '16 at 12:21
  • I have this same problem. She sounds very robotic, not like the iOS Siri voice at all. – Nathan Sep 25 '16 at 15:34
6

I had the same problem but figured it out. First of all, it does take some time for the high quality voice to silently download in the background, and get enabled. But for me, weeks went by and the low-quality voice remained. Here's why:

It has to do with your App Store System Preferences. I had all the checkboxes under "Automatically Check for updates" disabled, including "Install System Data Files and security updates". (This is to avoid any surprise bills when I'm tethering with my phone). Well, it turns out, when this is disabled, it won't download the voices from Apple's CDN (example URL: http://swcdn.apple.com/content/downloads/06/40/031-72924/0p9g9iuul9uaojp42eatzq4 b3zr38r4dgw/CustomVoice_en_GB_martha.pkg)

I haven't narrowed it down to this one checkbox (I enabled all of them) but I'm pretty sure it's the culprit. After enabling these checkboxes, I toggled Siri off and on a couple of times and watched the console - finally it downloaded and installed the voices and placed them in System/Library/Speech/Voices . You can keep an eye on System/Library/System/Library/Receipts to see when it actually installs the voices. Mystery solved (for me anyway).

Apple really needs to add a warning message or an override when you enable Siri if it's not going to be able to provide the high quality voice. It took hours of real digging to figure this out.

  • 1
    In App Store System Preferences, "Install System Data Files and Security Updates" was already enabled on my Mac. I also enabled other checkboxes to see if it helps. I toggled Siri off and on a few times, too. Still, after a couple of hours, Activity Monitor doesn't show any network activities at all. So I think that's not going to solve the problem for me. I wonder if it's possible to download Siri's voice manually? – ParsiKade Sep 30 '16 at 7:12
3
+100

As it turns out, Siri's enhanced voice quality doesn't come preinstalled on macOS Sierra (just like on iOS). After you install macOS Sierra, your Mac will start downloading Siri's enhanced voice, which is a ~1.35GB download.

If you're facing the same problem and you still can't hear Siri's enhanced voice, even after a few days of installing macOS Sierra (like what happened to me), I advise keeping your Mac plugged in and awake at night (or a couple of nights if you have a slow connection), the enhanced voice should download overnight when you're not using your Mac.

There is also a thread on MacRumors forums regarding this issue (http://forums.macrumors.com/threads/low-quality-siri-voice.1981561/).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .